aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-08 15:40:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-09 21:05:19 +0100
commitccecf9166578e28d19af87300f8bfd8854dab015 (patch)
treedc504182792200c5c1f4e08dd7fb108e2d94e639
parent672211e8344f13b8bc6e15017bfc84dbe43e0440 (diff)
downloadguix-ccecf9166578e28d19af87300f8bfd8854dab015.tar.gz
guix-ccecf9166578e28d19af87300f8bfd8854dab015.zip
gnu: Add go-github-com-mikioh-tcp.
* gnu/packages/golang-web.scm (go-github-com-mikioh-tcp): New variable. Change-Id: I423a98a726666d9eb145125f97a9198efdb2fb61
-rw-r--r--gnu/packages/golang-web.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b18498c66a..7eb72b54c6 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3151,6 +3151,44 @@ Domain Name Service}. The API follows the less-is-more principle, by
presenting a small interface.")
(license license:bsd-3)))
+(define-public go-github-com-mikioh-tcp
+ (package
+ (name "go-github-com-mikioh-tcp")
+ (version "0.0.0-20190314235350-803a9b46060c")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mikioh/tcp")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mwldbqkl6j4lzxar5pnvi946w0iifmw43rmanbwzp7ngx27fz5a"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mikioh/tcp"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "_test\\.go$")
+ ;; Get "https://golang.org/robots.txt": dial tcp: lookup
+ ;; golang.org on [::1]:53: read udp [::1]:47181->[::1]:53:
+ ;; read: connection refused.
+ (("TestInfo") "OffTestInfo"))))))))
+ (native-inputs
+ (list go-golang-org-x-net))
+ (propagated-inputs
+ (list go-github-com-mikioh-tcpinfo))
+ (home-page "https://github.com/mikioh/tcp")
+ (synopsis "TCP-level socket options implementation in Golang")
+ (description
+ "This package implements a TCP-level socket options that allow
+manipulation of TCP connection facilities.")
+ (license license:bsd-2)))
+
(define-public go-github-com-mikioh-tcpinfo
(package
(name "go-github-com-mikioh-tcpinfo")