aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-15 15:59:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:15:04 +0200
commitc75a1c9e369143720df398d81233a214bd241455 (patch)
tree3c300f086e1456921e46df4bb4de279119abf051
parent97aa14a2221eca6d65af8aeb079a97322d69252d (diff)
downloadguix-c75a1c9e369143720df398d81233a214bd241455.tar.gz
guix-c75a1c9e369143720df398d81233a214bd241455.zip
gnu: python-pyopenssl: Update to 24.2.1.
* gnu/packages/python-crypto.scm (python-pyopenssl): Update to 24.2.1. [source]: Update pypi-uri name. [arguments]: Adjust the 'check phase for the new release date. Change-Id: Iebf7ea8668233a70a05b8cea728734694c3c2dde
-rw-r--r--gnu/packages/python-crypto.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 3c13a17815..8eb8fd6a6d 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -624,14 +624,14 @@ ciphers, message digests and key derivation functions.")
(define-public python-pyopenssl
(package
(name "python-pyopenssl")
- (version "24.1.0")
+ (version "24.2.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "pyOpenSSL" version))
+ (uri (pypi-uri "pyopenssl" version))
(sha256
(base32
- "0vqsyji1q4vhd5yxlzks0z6va62knq64mxhfdjhz3yaxmazx9gna"))))
+ "158fpy6fsmkrci67qpzg06ha3ygh3ah3xzxjrc6md3blwgdz0is2"))))
(build-system python-build-system)
(arguments
(list
@@ -643,7 +643,7 @@ ciphers, message digests and key derivation functions.")
;; PyOpenSSL runs tests against a certificate with a fixed
;; expiry time. To ensure successful builds in the future,
;; set the time to roughly the release date.
- (invoke "faketime" "2024-03-09" "pytest" "-vv" "-k"
+ (invoke "faketime" "2024-07-20" "pytest" "-vv" "-k"
;; This test tries to look up certificates from
;; the compiled-in default path in OpenSSL, which
;; does not exist in the build environment.