aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-16 21:59:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:42:06 +0300
commitc645f4b3a199386d48741887685e84fe34baf285 (patch)
tree4f3c520fc0553e994c36eca23f48e963a444b6cf
parent1da1650488aa338c9afdd0bc489b0d49ac61df31 (diff)
downloadguix-c645f4b3a199386d48741887685e84fe34baf285.tar.gz
guix-c645f4b3a199386d48741887685e84fe34baf285.zip
gnu: Add rust-ref-thread-local-0.1.
* gnu/packages/crates-io.scm (rust-ref-thread-local-0.1): New variable. Change-Id: Ied65f12f79d61ee621f416d807532bb59a356168
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9e40262ef4..eaecac1aba 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56304,6 +56304,24 @@ initial value.")
(description "Test suite of the ref-cast crate.")
(license (list license:expat license:asl2.0))))
+(define-public rust-ref-thread-local-0.1
+ (package
+ (name "rust-ref-thread-local")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ref_thread_local" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1w7zw42bzywh9jfhlj5dswdh79dk7bvh4mmsamw9jy40lrh1dmd0"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/Xeiron/ref_thread_local.rs")
+ (synopsis "Macro for declaring thread-local `static`s")
+ (description "This package provides a macro for declaring thread-local
+`static`s like using both of `lazy_static!` and `@code{RefCell`}")
+ (license license:expat)))
+
(define-public rust-refpool-0.4
(package
(name "rust-refpool")