aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-14 11:03:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:41:15 +0300
commitc5f0efbb390c42095c66d3502aec8c78ab3fa516 (patch)
tree7544596155f8865b031e5e612f8bac0dcb96a9d1
parent58f662be44d037bc9d2fede5945914b6cf6b81e3 (diff)
downloadguix-c5f0efbb390c42095c66d3502aec8c78ab3fa516.tar.gz
guix-c5f0efbb390c42095c66d3502aec8c78ab3fa516.zip
gnu: Add rust-supports-hyperlinks-3.
* gnu/packages/crates-io.scm (rust-supports-hyperlinks-3): New variable. (rust-supports-hyperlinks-2): Inherit from rust-supports-hyperlinks-3. Change-Id: I88fcb4db704a0308cb031a44aee6b2e9c88439b2
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1c776c7b37..6974ed25dc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -66945,25 +66945,38 @@ values without proliferating generics.")
"Detects whether a terminal supports color, and gives details about that support.")
(license license:asl2.0)))
-(define-public rust-supports-hyperlinks-2
+(define-public rust-supports-hyperlinks-3
(package
(name "rust-supports-hyperlinks")
- (version "2.1.0")
+ (version "3.0.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "supports-hyperlinks" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0g93nh1db3f9lyd0ry35bqjrxkg6sbysn36x9hgd9m5h5rlk2hpq"))))
+ (base32 "1vh4wjflrpa0vadfirzn57glk1wwrdfxkxwgyqzmy7q4d18iw2ic"))))
(build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-is-terminal" ,rust-is-terminal-0.4))))
(home-page "https://github.com/zkat/supports-hyperlinks")
(synopsis "Detects whether a terminal supports rendering hyperlinks")
(description "Detects whether a terminal supports rendering hyperlinks.")
(license license:asl2.0)))
+(define-public rust-supports-hyperlinks-2
+ (package
+ (inherit rust-supports-hyperlinks-3)
+ (name "rust-supports-hyperlinks")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "supports-hyperlinks" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0g93nh1db3f9lyd0ry35bqjrxkg6sbysn36x9hgd9m5h5rlk2hpq"))))
+ (arguments
+ `(#:cargo-inputs (("rust-is-terminal" ,rust-is-terminal-0.4))))))
+
(define-public rust-sval-2
(package
(name "rust-sval")