aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-09-26 11:10:24 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-26 11:10:24 +0200
commitbc072c9a57b9eb97326aa48f4896412c12998cc2 (patch)
tree001f78bcf6ae2a9f45206b2393faa51250b7640d
parent4b551518d0a14a6ac1655bde3d23f6d189f49490 (diff)
downloadguix-bc072c9a57b9eb97326aa48f4896412c12998cc2.tar.gz
guix-bc072c9a57b9eb97326aa48f4896412c12998cc2.zip
etc: teams: Add description and scope for lisp team.
* etc/teams.scm.in (lisp): Add description and scope fields.
-rw-r--r--etc/teams.scm.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index cb593fb302..99d1d8168f 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -189,7 +189,14 @@ ecosystem."
(define-team lisp
(team 'lisp
- #:name "Lisp team"))
+ #:name "Lisp team"
+ #:description
+ "Common Lisp and similar languages, Common Lisp packages and the
+asdf-build-system."
+ #:scope (list (make-regexp "^gnu/packages/lisp(-.+|)\\.scm$")
+ "guix/build/asdf-build-system.scm"
+ "guix/build/lisp-utils.scm"
+ "guix/build-system/asdf.scm")))
(define-team ruby
(team 'ruby
lass='head'>diff --git a/gnu/packages/patches/ath9k-htc-firmware-gcc-compat.patch b/gnu/packages/patches/ath9k-htc-firmware-gcc-compat.patch
new file mode 100644
index 0000000000..ceada2fa24
--- /dev/null
+++ b/gnu/packages/patches/ath9k-htc-firmware-gcc-compat.patch
@@ -0,0 +1,29 @@
+Fixes for compiling with -fno-common, default in GCC 10.
+
+Taken from upstream:
+https://github.com/qca/open-ath9k-htc-firmware/commit/559e3eba3b4cf103da6b8d022f3e1387278b9db8
+
+diff --git a/target_firmware/magpie_fw_dev/target/init/app_start.c b/target_firmware/magpie_fw_dev/target/init/app_start.c
+--- a/target_firmware/magpie_fw_dev/target/init/app_start.c
++++ b/target_firmware/magpie_fw_dev/target/init/app_start.c
+@@ -52,6 +52,8 @@
+ #define ALLOCRAM_START ( ((unsigned int)&_fw_image_end) + 4)
+ #define ALLOCRAM_SIZE ( SYS_RAM_SZIE - ( ALLOCRAM_START - SYS_D_RAM_REGION_0_BASE) - SYS_D_RAM_STACK_SIZE)
+
++void (* _assfail_ori)(struct register_dump_s *);
++
+ // support for more than 64 bytes on command pipe
+ extern void usb_reg_out_patch(void);
+ extern int _HIFusb_get_max_msg_len_patch(hif_handle_t handle, int pipe);
+diff --git a/target_firmware/magpie_fw_dev/target/init/init.h b/target_firmware/magpie_fw_dev/target/init/init.h
+--- a/target_firmware/magpie_fw_dev/target/init/init.h
++++ b/target_firmware/magpie_fw_dev/target/init/init.h
+@@ -46,7 +46,7 @@
+ void AR6002_fatal_exception_handler_patch(CPU_exception_frame_t *exc_frame);
+ void exception_reset(struct register_dump_s *dump);
+
+-void (* _assfail_ori)(struct register_dump_s *);
++extern void (* _assfail_ori)(struct register_dump_s *);
+ void HTCMsgRecvHandler_patch(adf_nbuf_t hdr_buf, adf_nbuf_t buffer, void *context);
+ void HTCControlSvcProcessMsg_patch(HTC_ENDPOINT_ID EndpointID, adf_nbuf_t hdr_buf,
+ adf_nbuf_t pBuffers, void *arg);