aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:34:09 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:13 +0200
commitb98209bd56256492c43442c36a9eaa697160e185 (patch)
tree425cfa46ef4066950456d35c43d06031cd3d5edc
parent78b035ae203c0595c4cef302b3411b3d88a27bb6 (diff)
downloadguix-b98209bd56256492c43442c36a9eaa697160e185.tar.gz
guix-b98209bd56256492c43442c36a9eaa697160e185.zip
gnu: emacs-hcl-mode: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-hcl-mode)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1d2c9a0e7e..0b65146fbb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8663,14 +8663,13 @@ the pipeline, featuring the support for running @code{emacsclient}.")
(version "0.03")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/syohex/emacs-hcl-mode/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/syohex/emacs-hcl-mode.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0pvw74qpwh0znqzp6syp4wxjqs7dp1hbn5h7xfk97mff9l5d8k6x"))))
+ (base32 "0jqrgq15jz6pvx38pnwkizzfiih0d3nxqphyrc92nqpcyimg8b6g"))))
(build-system emacs-build-system)
(home-page "https://github.com/syohex/emacs-hcl-mode")
(synopsis "Major mode for the Hashicorp Configuration Language")