aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-19 15:19:58 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-22 15:20:49 +0900
commitb7c94d528875415ea7ec6225d88a6b3d55fa2e14 (patch)
tree3d3b0bacf6684772e34b86e6492273967e8a1fc9
parent55db928dcbb73d6d03c1af30b070cd65c835109d (diff)
downloadguix-b7c94d528875415ea7ec6225d88a6b3d55fa2e14.tar.gz
guix-b7c94d528875415ea7ec6225d88a6b3d55fa2e14.zip
gnu: Add sdl-jstest.
* gnu/packages/games.scm (sdl-jstest): New variable. Change-Id: I8a2845375501ddadca2eb4add869fce1dc277568
-rw-r--r--gnu/packages/games.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9f02f32864..63e2c2a5bf 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11430,6 +11430,45 @@ do so you need to explore the island, find food, build a shelter and try to
get attention, so you get found.")
(license license:cc-by4.0))))
+(define-public sdl-jstest
+ (package
+ (name "sdl-jstest")
+ (version "0.2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Grumbel/sdl-jstest")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11qp4gkbb11n3wx74128fj56radgsvkj7nxhbh55rd3xad1hckh3"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ ;; The test suite uses appstream-utils to validate the appdata.xml file,
+ ;; fails with "url-not-found".
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'copy-gamecontroller-db
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (copy-file
+ (search-input-file (or native-inputs inputs)
+ "share/sdl2/gamecontrollerdb.txt")
+ "external/sdl_gamecontrollerdb/gamecontrollerdb.txt"))))))
+ (native-inputs
+ (list pkg-config sdl2-gamecontrollerdb tinycmmc))
+ (inputs (list ncurses sdl sdl2))
+ (home-page "https://github.com/Grumbel/sdl-jstest")
+ (synopsis "SDL Joystick Tester")
+ (description "The @command{sdl-jstest} and @command{sdl2-jstest} commands
+can list the available joystick controllers as found by the SDL or SDL2
+libraries, respectively. It can show the available axes, buttons, hats and
+balls of a chosen controller, and can display the controller actions in real
+time in a visual fashion.")
+ (license license:gpl3+)))
+
(define-public sdlpop
(package
(name "sdlpop")