aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 14:31:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 14:31:39 +0200
commitb6ca418c88f9510515b82af2a2bb443c777034d3 (patch)
tree97acc634f6f9c5f42809f6dd399b015a88d27222
parent1b2d43fe016848ea2ec16ff18cbc14340944fc4e (diff)
downloadguix-b6ca418c88f9510515b82af2a2bb443c777034d3.tar.gz
guix-b6ca418c88f9510515b82af2a2bb443c777034d3.zip
gnu: Add texlive-crossword.
* gnu/packages/tex.scm (texlive-crossword): New variable.
-rw-r--r--gnu/packages/tex.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d01c31e7db..e97c398ae0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4811,6 +4811,45 @@ with a wide array of formats. For the moment, it works out of the box with
ConTeXt and LaTeX.")
(license (list license:gpl3+ license:fdl1.3+))))
+(define-public texlive-crossword
+ (package
+ (name "texlive-crossword")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/crossword/"
+ "source/latex/crossword/"
+ "tex/latex/crossword/")
+ (base32
+ "1yxjhni6jw7j7wnz6g6d1bmri8afvqsj58bar0aqliyfhr55xzai")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/crossword")
+ (synopsis "Typeset crossword puzzles")
+ (description
+ "This is an extended grid-based puzzle package, designed to take all
+input (both grid and clues) from the same file. The package can
+typeset grids with holes in them, and can deal with several sorts of
+puzzle:
+@itemize
+
+@item the classical puzzle contains numbers for the words and clues
+for the words to be filled in;
+
+@item the numbered puzzle contains numbers in each cell where
+identical numbers represent identical letters; the goal is to find out
+which number corresponds to which letter;
+
+@item the fill-in type of puzzle consists of a grid and a list of
+words; the goal is to place all words in the grid;
+
+@item Sudoku and Kakuro puzzles involve filling in grids of numbers
+according to their own rules; format may be block-separated, or
+separated by thick lines.
+
+@end itemize")
+ (license license:expat)))
+
(define-public texlive-cryptocode
(package
(name "texlive-cryptocode")