aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2025-03-06 23:35:38 +0000
committerRicardo Wurmus <rekado@elephly.net>2025-03-07 12:35:23 +0100
commitb44031fa8795c629dc46dc75d9870e5b1d8fb8b5 (patch)
treea6adfa78e81a7a29ea345c56a2f65dca1120066a
parent5e62df044d415d98e334abb44ab5abc6f6917dc6 (diff)
downloadguix-b44031fa8795c629dc46dc75d9870e5b1d8fb8b5.tar.gz
guix-b44031fa8795c629dc46dc75d9870e5b1d8fb8b5.zip
gnu: Add sickle.
* gnu/packages/bioinformatics.scm (sickle): New variable. Change-Id: Ib74974b0ee887753d6ead5b5b388e7163abb11f8
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d2959e1401..0825fbb6ef 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14542,6 +14542,39 @@ provide error correction, haplotype reconstruction and estimation of the
frequency of the different genetic variants present in a mixed sample.")
(license license:gpl3+)))
+(define-public sickle
+ (package
+ (name "sickle")
+ (version "1.33")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/najoshi/sickle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bnq480lpylq9sfsa1y71b4qz0ipi2zjnp8ds48fh10ijlwmwmdc"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;There are no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "sickle" (string-append #$output "/bin")))))))
+ (propagated-inputs (list zlib))
+ (home-page "https://github.com/najoshi/sickle")
+ (synopsis "Adaptive trimming tool for FASTQ files using quality")
+ (description
+ "Sickle is a tool that trims reads based on quality and length
+thresholds. It uses sliding windows to detect low-quality bases at the 3'-end
+and high-quality bases at the 5'-end. Additionally, it discards reads based
+on the length threshold.")
+ (license license:expat)))
+
(define-public ruby-bio-kseq
(package
(name "ruby-bio-kseq")