aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:59 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commitb187cba93570b91133664cafddcf3c8fb67f4ae3 (patch)
tree79a9f0c18ea6e4a7eb5f42b601cd55b866b327f0
parentdf549fd893162a6bf3a32309f26d7c710895293c (diff)
downloadguix-b187cba93570b91133664cafddcf3c8fb67f4ae3.tar.gz
guix-b187cba93570b91133664cafddcf3c8fb67f4ae3.zip
gnu: Add trytond-web-shortener.
* gnu/packages/tryton.scm (trytond-web-shortener): New variable.
-rw-r--r--gnu/packages/tryton.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 5a74a5f4e3..c86a27e05b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4468,3 +4468,25 @@ Vue Storefront 1.x.")
(description "The @emph{Web Shop Vue Storefront Stripe} Tryton module
provides support of Stripe payment for Vue Storefront integration.")
(license license:gpl3+)))
+
+(define-public trytond-web-shortener
+ (package
+ (name "trytond-web-shortener")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_web_shortener" version))
+ (sha256
+ (base32 "0vxwnsy7xzxawn7fmm6ykdrhih6ahrwwx6fzd6kz7qbwh4nmqcpk"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "web_shortener"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)))
+ (home-page "https://docs.tryton.org/projects/modules-web-shortener")
+ (synopsis "Tryton module to plug a URL to an action")
+ (description "The @emph{Web Shortener} Tryton module allows URLs to be
+shortened. It also counts the number of times the URL is accessed and
+optionally triggers action.")
+ (license license:gpl3+)))
ello\"); }" port))) (invoke c-compiler "t.c" "-Wl,--enable-new-dtags" "-Wl,-rpath=/foo" "-Wl,-rpath=/bar") (let* ((dyninfo (elf-dynamic-info (parse-elf (call-with-input-file "a.out" get-bytevector-all)))) (old (elf-dynamic-info-runpath dyninfo)) (new (strip-runpath "a.out")) (new* (strip-runpath "a.out"))) (validate-needed-in-runpath "a.out") (and (member "/foo" old) (member "/bar" old) (not (member "/foo" new)) (not (member "/bar" new)) (equal? new* new) (let* ((pipe (open-input-pipe "./a.out")) (str (get-string-all pipe))) (close-pipe pipe) str))))))) (unless c-compiler (test-skip 1)) (test-equal "set-file-runpath + file-runpath" "hello\n" (call-with-temporary-directory (lambda (directory) (with-directory-excursion directory (call-with-output-file "t.c" (lambda (port) (display "#include <stdio.h>\n" port) (display "int main () { puts(\"hello\"); }" port))) (invoke c-compiler "t.c" "-Wl,--enable-new-dtags" "-Wl,-rpath=/xxxxxxxxx") (let ((original-runpath (file-runpath "a.out"))) (and (member "/xxxxxxxxx" original-runpath) (guard (c ((runpath-too-long-error? c) (string=? "a.out" (runpath-too-long-error-file c)))) (set-file-runpath "a.out" (list (make-string 777 #\y)))) (let ((runpath (delete "/xxxxxxxxx" original-runpath))) (set-file-runpath "a.out" runpath) (equal? runpath (file-runpath "a.out"))) (let* ((pipe (open-input-pipe "./a.out")) (str (get-string-all pipe))) (close-pipe pipe) str))))))) (unless c-compiler (test-skip 1)) (test-equal "elf-dynamic-info-soname" "libfoo.so.2" (call-with-temporary-directory (lambda (directory) (with-directory-excursion directory (call-with-output-file "t.c" (lambda (port) (display "// empty file" port))) (invoke c-compiler "t.c" "-shared" "-Wl,-soname,libfoo.so.2") (let* ((dyninfo (elf-dynamic-info (parse-elf (call-with-input-file "a.out" get-bytevector-all)))) (soname (elf-dynamic-info-soname dyninfo))) soname))))) (test-end "gremlin")