aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-27 13:31:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:19:41 +0200
commitb18354b065057a846bb0141b8e3c5c72eef73afa (patch)
tree0040b3c52a00cbcf301f045d2a9007131a407c96
parentae2667966ffbdd5a6b6c1bedc50a926c90cd0c9d (diff)
downloadguix-b18354b065057a846bb0141b8e3c5c72eef73afa.tar.gz
guix-b18354b065057a846bb0141b8e3c5c72eef73afa.zip
gnu: Add rust-tiny-bench-0.3.
* gnu/packages/crates-check.scm (rust-tiny-bench-0.3): New variable. Change-Id: Id6848a8d243d10a22812ea4b7a92484f974673f3
-rw-r--r--gnu/packages/crates-check.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/crates-check.scm b/gnu/packages/crates-check.scm
index 5ffb460c90..5bb0676ab2 100644
--- a/gnu/packages/crates-check.scm
+++ b/gnu/packages/crates-check.scm
@@ -764,6 +764,23 @@ integers, floats, tuples, booleans, lists, strings, options and results.")
#:cargo-development-inputs
(("rust-quickcheck" ,rust-quickcheck-0.8))))))
+(define-public rust-tiny-bench-0.3
+ (package
+ (name "rust-tiny-bench")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tiny-bench" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0j2rsyspqbk89y6zjndpc6d36ljir1ymyj15vv6jxhaphl6q9nng"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/EmbarkStudios/tiny-bench")
+ (synopsis "tiny benchmarking library")
+ (description "This package provides a tiny benchmarking library.")
+ (license (list license:expat license:asl2.0))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar