aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-11-07 23:21:53 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:23 +0200
commitaf10a7ef291a495d34ccd4a01d09fcde5cfc7f70 (patch)
treeef590b62f7b9fd46851300c7fd9ed2ab37d291d6
parent2742ba7ad01a9a5d7659631d7506dc440999d178 (diff)
downloadguix-af10a7ef291a495d34ccd4a01d09fcde5cfc7f70.tar.gz
guix-af10a7ef291a495d34ccd4a01d09fcde5cfc7f70.zip
gnu: Add rust-atomic-refcell-0.1.
* gnu/packages/crates-io.scm (rust-atomic-refcell-0.1): New variable. Change-Id: I8ae9a09e5d1349358a3b20b71c7e150a4b8cfc53 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7f5c5b284d..2c9deb5068 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6219,6 +6219,26 @@ they're not available.")
they're not available.")
(license (list license:expat license:asl2.0))))
+(define-public rust-atomic-refcell-0.1
+ (package
+ (name "rust-atomic-refcell")
+ (version "0.1.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "atomic_refcell" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0z04ng59y22mwf315wamx78ybhjag0x6k7isc36hdgcv63c7rrj1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-serde" ,rust-serde-1))
+ #:cargo-development-inputs (("rust-serde-json" ,rust-serde-json-1))))
+ (home-page "https://github.com/bholley/atomic_refcell")
+ (synopsis "Threadsafe RefCell")
+ (description "This package provides Threadsafe @code{RefCell}.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-atomic-take-1
(package
(name "rust-atomic-take")