aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:07:43 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:54 +0200
commitaefed76de00a12c004f039aca83daf08aa066af1 (patch)
tree2846a1219876b4eccd9ed84a02e348937f906155
parentd19ddc9450e98ca7adcd65072754e8f727bcd982 (diff)
downloadguix-aefed76de00a12c004f039aca83daf08aa066af1.tar.gz
guix-aefed76de00a12c004f039aca83daf08aa066af1.zip
gnu: ldb: Remove reference to crypt.
* gnu/packages/samba.scm (ldb): Remove reference to crypt header. Change-Id: Idcf43ff9b140d5c7e601d853564833525396e565
-rw-r--r--gnu/packages/samba.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 2d1ea5959d..ae3966664f 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -451,6 +451,14 @@ many event types, including timers, signals, and the classic file descriptor eve
#:tests? (assoc-ref %build-inputs "lmdb")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-crypt-reference
+ ;; The following is needed because Python.h propagates
+ ;; HAVE_CRYPT_H, which is then seen from lib/replace/ but talloc
+ ;; doesn't need it at all.
+ (lambda _
+ (substitute* "lib/replace/replace.h"
+ (("#include <crypt.h>")
+ ""))))
(replace 'configure
;; ldb use a custom configuration script that runs waf.
(lambda* (#:key outputs #:allow-other-keys)