aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-28 15:41:32 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-29 08:38:26 +0100
commitaee92957b5032196cb830f0288557de864c9c644 (patch)
treef8a9185f3ee317947ee52f64bd119ff9edcf7761
parent0bb322014084ee76f193bbc3348f29479f014e23 (diff)
downloadguix-aee92957b5032196cb830f0288557de864c9c644.tar.gz
guix-aee92957b5032196cb830f0288557de864c9c644.zip
gnu: Add python-memcached.
* gnu/packages/python-xyz.scm (python-memcached): New public variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index edca719547..e082351e36 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10664,6 +10664,28 @@ implementation as been adapted, improved and fixed from Molten.")
running in.")
(license license:isc)))
+(define-public python-memcached
+ (package
+ (name "python-memcached")
+ (version "1.59")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-memcached" version))
+ (sha256
+ (base32
+ "0kvyapavbirk2x3n1jx4yb9nyigrj1s3x15nm3qhpvhkpqvqdqm2"))))
+ (build-system python-build-system)
+ (propagated-inputs `(("python-six" ,python-six)))
+ (home-page
+ "https://github.com/linsomniac/python-memcached")
+ (synopsis "Pure python memcached client")
+ (description
+ "This software is a pure Python interface to the memcached memory cache
+daemon. It is the client side software which allows storing values in one or
+more, possibly remote, memcached servers.")
+ (license license:psfl)))
+
(define-public python-lazy-object-proxy
(package
(name "python-lazy-object-proxy")
ix/packages/i686-linux/20121219/guile-2.0.7.tar.xz; sha256 = "45d1f9bfb9e4531a8f1c5a105f7ab094cd481b8a179ccc63cbabb73ce6b8437f"; }; x86_64 = pkgs.fetchurl { url = http://www.fdn.fr/~lcourtes/software/guix/packages/x86_64-linux/20121219/guile-2.0.7.tar.xz; sha256 = "953fbcc8db6e310626be79b67319cf4141dc23b296447952a99d95425b3a4dc1"; }; }; jobs = { tarball = let pkgs = import nixpkgs {}; in pkgs.releaseTools.sourceTarball { name = "guix-tarball"; src = <guix>; buildInputs = with pkgs; [ guile sqlite bzip2 git libgcrypt ]; buildNativeInputs = with pkgs; [ texinfo gettext cvs pkgconfig ]; preAutoconf = ''git config submodule.nix.url "${<nix>}"''; configureFlags = [ "--with-libgcrypt-prefix=${pkgs.libgcrypt}" "--localstatedir=/nix/var" ]; }; build = { system ? builtins.currentSystem }: let pkgs = import nixpkgs { inherit system; }; in pkgs.releaseTools.nixBuild { name = "guix"; buildInputs = with pkgs; [ guile sqlite bzip2 libgcrypt ]; buildNativeInputs = [ pkgs.pkgconfig ]; src = jobs.tarball; configureFlags = [ "--with-libgcrypt-prefix=${pkgs.libgcrypt}" "--localstatedir=/nix/var" ]; preBuild = # Use our pre-downloaded bootstrap tarballs instead of letting # the build system download it over and over again. '' mkdir -p distro/packages/bootstrap/{i686,x86_64}-linux cp -v "${bootstrap_guile.i686}" \ distro/packages/bootstrap/i686-linux/guile-2.0.7.tar.xz cp -v "${bootstrap_guile.x86_64}" \ distro/packages/bootstrap/x86_64-linux/guile-2.0.7.tar.xz ''; inherit succeedOnFailure keepBuildDirectory buildOutOfSourceTree; }; build_disable_daemon = { system ? builtins.currentSystem }: let pkgs = import nixpkgs { inherit system; }; build = jobs.build { inherit system; }; in pkgs.lib.overrideDerivation build ({ configureFlags, ... }: { configureFlags = configureFlags ++ [ "--disable-daemon" ]; buildInputs = with pkgs; [ guile nixUnstable pkgconfig ]; # Since we need to talk to a running daemon, we need to escape # the chroot. preConfigure = "export NIX_REMOTE=daemon"; __noChroot = true; }); # Jobs to test the distro. distro = { hello = { system ? builtins.currentSystem }: let pkgs = import nixpkgs { inherit system; }; guix = jobs.build { inherit system; }; in # XXX: We have no way to tell the Nix code to swallow the .drv # produced by `guix-build', so we have a pointless indirection # here. This could be worked around by generating Nix code # from the .drv, and importing that. pkgs.releaseTools.nixBuild { src = null; name = "guix-hello"; phases = "buildPhase"; buildPhase = "${guix}/bin/guix-build --no-substitutes hello | tee $out"; __noChroot = true; }; }; }; in jobs