aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCayetano Santos <csantosb@inventati.org>2025-02-20 14:58:21 +0100
committerLudovic Courtès <ludo@gnu.org>2025-02-21 15:27:11 +0100
commitabc45761abe9c3b367bca95c4dd52c1f589aee5f (patch)
treee706e48913b34e253995dc27195ea4f018219329
parentbff76fe66abd83d4986a758731dad404c40e2ca3 (diff)
downloadguix-abc45761abe9c3b367bca95c4dd52c1f589aee5f.tar.gz
guix-abc45761abe9c3b367bca95c4dd52c1f589aee5f.zip
gnu: Add python-pytooling.
* gnu/packages/python-xyz.scm (python-pytooling): New variable. Change-Id: Id045f071b6c531d4afff4322d1a544589f214d50 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9f626b51c1..a877515ff5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2588,6 +2588,32 @@ Python tools, such as rope and add support for a @file{pyproject.toml}
configuration file.")
(license license:lgpl3+)))
+(define-public python-pytooling
+ (package
+ (name "python-pytooling")
+ (version "8.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pyTooling/pyTooling/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07mca75d2zd6xl0isf0vrcblsc2niyqi7941dgjpiafnsgiygfzf"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:tests? #f)) ; requires recent versions of mypy and lxml
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://pytooling.github.io/pyTooling/")
+ (synopsis "Miscellaneous Python tools")
+ (description
+ "pyTooling is a collection of (abstract) data models, lacking classes,
+decorators, a new performance boosting meta-class, and enhanced exceptions.
+It also provides lots of helper functions---e.g., to ease the handling of
+package descriptions or to unify multiple existing APIs into a single API.")
+ (license license:asl2.0)))
+
(define-public python-colorlog
(package
(name "python-colorlog")