aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-12-22 17:26:49 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-01-01 13:05:04 +0100
commitab81e930a4980acee952a47be3bc527ed87084b4 (patch)
tree89d8257f3161038c588d9f9ca9acb3936f746b16
parent5ae2849a6874b6eca2fede89b970b199a0cd428a (diff)
downloadguix-ab81e930a4980acee952a47be3bc527ed87084b4.tar.gz
guix-ab81e930a4980acee952a47be3bc527ed87084b4.zip
gnu: Add python-pytz-deprecation-shim.
* gnu/packages/time.scm (python-pytz-deprecation-shim): New variable. Change-Id: I481ea9818444d9a14efcf7b11d44c68a5f2fec3f Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/time.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index f1aeae7340..0d84dee178 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2024 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -169,6 +170,31 @@ expressions.")
(description "This package provides a thin Python wrapper around tzdata.")
(license asl2.0)))
+(define-public python-pytz-deprecation-shim
+ (package
+ (name "python-pytz-deprecation-shim")
+ (version "0.1.0.post0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytz_deprecation_shim" version))
+ (sha256
+ (base32 "17d58msbi18dc4lk29hcrgylvrv9vhniwi24axfdwvb13fp7n2dg"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-dateutil python-tzdata))
+ (native-inputs (list python-pytest
+ python-pytz
+ python-setuptools
+ python-wheel))
+ (home-page "https://github.com/pganssle/pytz-deprecation-shim")
+ (synopsis "Shims to make deprecation of pytz easier")
+ (description
+ "This package aims to make the transition away from @code{pytz} easier.
+It is intended for temporary usage only, and should allow you to drop your
+dependency on @code{pytz} while also giving your users notice that eventually
+you will remove support for the pytz-specific interface.")
+ (license asl2.0)))
+
(define-public python-pytz
(package
(name "python-pytz")