aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-02-18 22:02:36 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:40:58 +0300
commita7b4afc692f63dd2d7f5e96b5a63f2b09e58ea7c (patch)
tree3ca23211477986e12a4a82af79907478b77d4695
parent9a54fcb7729df6fc1fd9c847880348c2b9b4e142 (diff)
downloadguix-a7b4afc692f63dd2d7f5e96b5a63f2b09e58ea7c.tar.gz
guix-a7b4afc692f63dd2d7f5e96b5a63f2b09e58ea7c.zip
gnu: Add rust-parse-display-derive-0.8.
* gnu/packages/crates-io.scm (rust-parse-display-derive-0.8): Add variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: I386da87ecf33e52bcd30a9a0c53a1eedd0811f1e
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index da0e26b7e5..d4f5c2bf1f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45850,6 +45850,34 @@ definitions compiled to support read+write async.")
parallelism and safety in mind.")
(license license:asl2.0)))
+(define-public rust-parse-display-derive-0.8
+ (package
+ (name "rust-parse-display-derive")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "parse-display-derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0hgkhjnk0xlaixql207p7vvg41vyq7y7gdqdijh8vxysr297hlb8"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-once-cell" ,rust-once-cell-1)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-regex-syntax" ,rust-regex-syntax-0.7)
+ ("rust-structmeta" ,rust-structmeta-0.2)
+ ("rust-syn" ,rust-syn-2))))
+ (home-page "https://github.com/frozenlib/parse-display")
+ (synopsis
+ "Procedural macro to implement Display and FromStr using common settings")
+ (description
+ "This package provides a procedural macro to implement @code{Display} and
+@code{FromStr} using common settings.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-parse-zoneinfo-0.3
(package
(name "rust-parse-zoneinfo")