aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-11 15:46:47 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-11 22:53:38 -0400
commita5b5df7f7fbbb98487b2e7a59941efee6492bc7f (patch)
tree6fe71db06bc9cac0456c59da14c05aecc7f40bae
parent5ff9afb5fdc6e34936683524907343859976a805 (diff)
downloadguix-a5b5df7f7fbbb98487b2e7a59941efee6492bc7f.tar.gz
guix-a5b5df7f7fbbb98487b2e7a59941efee6492bc7f.zip
gnu-maintenance: Support URI list of mixed mirrors, HTTP URLs.
Fixes <https://issues.guix.gnu.org/58697>. * guix/gnu-maintenance.scm (import-html-updatable-release): Update doc. <expand-uri>: New nested procedure. Apply it to the origin URI. Reported-by: kiasoc5 <kiasoc5@disroot.org>
-rw-r--r--guix/gnu-maintenance.scm29
1 files changed, 18 insertions, 11 deletions
diff --git a/guix/gnu-maintenance.scm b/guix/gnu-maintenance.scm
index 5a84fcb117..302243559d 100644
--- a/guix/gnu-maintenance.scm
+++ b/guix/gnu-maintenance.scm
@@ -975,17 +975,24 @@ updater."
((url-predicate http-url?) package)))
(define* (import-html-updatable-release package #:key (version #f))
- "Return the latest release of PACKAGE. Do that by crawling the HTML page of
-the directory containing its source tarball. Optionally include a VERSION
-string to fetch a specific version."
- (let* ((uri (string->uri
- (match (origin-uri (package-source package))
- ((and (? string?)
- (? (cut string-prefix? "mirror://" <>) url))
- ;; Retrieve the authoritative HTTP URL from a mirror.
- (http-url? url))
- ((? string? url) url)
- ((url _ ...) url))))
+ "Return the latest release of PACKAGE else #f. Do that by crawling the HTML
+page of the directory containing its source tarball. Optionally include a
+VERSION string to fetch a specific version."
+
+ (define (expand-uri uri)
+ (string->uri
+ (match uri
+ ((and (? string?) (? (cut string-prefix? "mirror://" <>) url))
+ ;; Retrieve the authoritative HTTP URL from a mirror.
+ (http-url? url))
+ ((? string? url)
+ url)
+ ((url _ ...)
+ ;; This case is for when the URI is a list of possibly mirror URLs as
+ ;; well as HTTP URLs.
+ (expand-uri url)))))
+
+ (let* ((uri (expand-uri (origin-uri (package-source package))))
(custom (assoc-ref (package-properties package)
'release-monitoring-url))
(base (or custom
/packages/guile.scm?id=14cd517e0cb8829b06b5a49f91c762c4a0e52eb5'>gnu: guile: Fix 'posix_spawn' usage for GNU/Hurd....* gnu/packages/guile.scm (guile-3.0)[arguments]: Add 'patch-posix-spawn-usage' phase. * gnu/packages/patches/guile-hurd-posix-spawn.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Ludovic Courtès 2023-03-30gnu: guile-readline: Switch to gexps....* gnu/packages/guile.scm (make-guile-readline): Switch to gexps. Ludovic Courtès 2023-03-30gnu: guile: Switch to gexps....* gnu/packages/guile.scm (guile-3.0)[arguments]: Switch to gexps. (guile-next)[arguments]: Likewise. Ludovic Courtès 2023-03-24gnu: guile-3.0-latest: Add patch for invalid unicode handling....This patch fixes handling of invalid unicode when using suspendable ports. Reported upstream at https://debbugs.gnu.org/cgi/bugreport.cgi?bug=62290 and patch merged as cba2e7e3fec3c781230570f5d1ef070625eeeda8. As the build coordinator agents use suspendable ports, this will fix issues with building things where the log output contains invalid unicode. * gnu/packages/patches/guile-fix-invalid-unicode-handling.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/guile.scm (guile-3.0-latest)[source]: Use it. Signed-off-by: Christopher Baines <mail@cbaines.net> Christopher Baines 2023-03-03gnu: guile: Fix cross-compilation....Fixes a regression introduced in d427ec403800dc5b0b69f3d7c259a7d62eb6c881, which changed the label of Bash from "bash" to "bash-minimal" when cross-compiling. * gnu/packages/guile.scm (guile-2.0)[arguments]: In 'pre-configure' phase, use 'search-input-file' when (%current-target-system) is true. Ludovic Courtès 2023-03-02gnu: libgc: Update to 8.2.2 and remove '--disable-munmap'....* gnu/packages/bdw-gc.scm (libgc): Update to 8.2.2. [arguments]: Remove "--disable-munmap" from #:configure-flags. * gnu/packages/guile.scm (guile-3.0)[source]: Leave 'test-out-of-memory' test untouched. (guile-next)[arguments]: Likewise, in 'skip-failing-tests' phase. (guile-for-guile-emacs)[arguments]: Likewise, in 'bootstrap' phase. Ludovic Courtès 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-02-26gnu: guile: Remove input labels....* gnu/packages/base.scm (libiconv-if-needed): Remove input label. * gnu/packages/guile.scm (guile-2.0)[native-inputs, inputs] [propagated-inputs]: Remove labels. (guile-next)[native-inputs]: Change "self" to "guile". (make-guile-readline): Adjust 'inputs' and 'propagated-inputs' accordingly. Ludovic Courtès