aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-03-24 19:52:22 +0800
committer宋文武 <iyzsong@gmail.com>2015-03-26 07:30:59 +0800
commita31a6d22d64b2627437e0e25529cf37caf79f4dd (patch)
treebf2eb467cac0f5eb4c1a2f43213b8cfe1dac66d5
parent4c153a9125fa0913077b06b5ed537958ae4ca163 (diff)
downloadguix-a31a6d22d64b2627437e0e25529cf37caf79f4dd.tar.gz
guix-a31a6d22d64b2627437e0e25529cf37caf79f4dd.zip
gnu: Add gnome-mines.
* gnu/packages/gnome.scm (gnome-mines): New variable.
-rw-r--r--gnu/packages/gnome.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3b70e27816..0e674da899 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1621,3 +1621,48 @@ library.")
;; This is the license of the rsvg bindings. The license of each module
;; of gnome-python-desktop is given in 'COPYING'.
(license license:lgpl2.1+)))
+
+(define-public gnome-mines
+ (package
+ (name "gnome-mines")
+ (version "3.14.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0nbgvzlsznn3v83pdcx2d52r4ig1mvaijh633rjddx9rgq2ja7kv"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before configure patch-/bin/true
+ (lambda _
+ (substitute* "configure"
+ (("/bin/true") (which "true")))))
+ (add-after install wrap-pixbuf
+ ;; Use librsvg's loaders.cache to support SVG files.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (prog (string-append out "/bin/gnome-mines"))
+ (rsvg (assoc-ref inputs "librsvg"))
+ (pixbuf (find-files rsvg "^loaders\\.cache$")))
+ (wrap-program prog
+ `("GDK_PIXBUF_MODULE_FILE" = ,pixbuf))))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("librsvg" ,librsvg)))
+ (home-page "https://wiki.gnome.org/Apps/Mines")
+ (synopsis "Minesweeper game")
+ (description
+ "Mines (previously gnomine) is a puzzle game where you locate mines
+floating in an ocean using only your brain and a little bit of luck.")
+ (license license:gpl2+)))
dd'>+ (mkdir-p font-dir)
+ (mkdir-p doc-dir)
+ (chdir (string-append "liberation-fonts-ttf-" ,version))
+ (for-each (lambda (ttf)
+ (copy-file ttf
+ (string-append font-dir "/"
+ (basename ttf))))
+ (find-files "." "\\.ttf$"))
+ (for-each (lambda (doc)
+ (copy-file doc
+ (string-append doc-dir "/"
+ (basename doc))))
+ '("AUTHORS" "ChangeLog" "LICENSE" "README" "TODO"))))))
+ (native-inputs
+ `(("source" ,source)
+ ("tar" ,tar)
+ ("gzip" ,gzip)))
+ (home-page "https://fedorahosted.org/liberation-fonts/")
+ (synopsis
+ "Fonts compatible with Arial, Times New Roman, and Courier New")
+ (description
+ "The Liberation font family aims at metric compatibility with
+Arial, Times New Roman, and Courier New.
+
+There are three sets:
+
+- Sans (a substitute for Arial, Albany, Helvetica, Nimbus Sans L, and
+Bitstream Vera Sans);
+
+- Serif (a substitute for Times New Roman, Thorndale, Nimbus Roman, and
+Bitstream Vera Serif);
+
+- Mono (a substitute for Courier New, Cumberland, Courier, Nimbus Mono L,
+and Bitstream Vera Sans Mono).
+
+The Liberation Fonts are sponsored by Red Hat.")
+ (license license:silofl1.1)))
+
+(define-public font-terminus
+ (package
+ (name "font-terminus")
(version "4.39")
(source
(origin