aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:24:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:41 +0200
commit9d2c60cf16d04d1ff09ee7544e35ee8d255b3dfc (patch)
treefcac6fded388430eefbc383c8ab2bcb7195af402
parentc69faf82a2adcb32327d0595f6e7637d45486bea (diff)
downloadguix-9d2c60cf16d04d1ff09ee7544e35ee8d255b3dfc.tar.gz
guix-9d2c60cf16d04d1ff09ee7544e35ee8d255b3dfc.zip
gnu: Add texlive-rviewport.
* gnu/packages/tex.scm (texlive-rviewport): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b741bb1626..a5734b4e88 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3751,6 +3751,34 @@ steps can be customized in various ways.")
example to be used in educational material.")
(license license:lppl1.3+)))
+(define-public texlive-rviewport
+ (package
+ (name "texlive-rviewport")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/rviewport/"
+ "source/latex/rviewport/"
+ "tex/latex/rviewport/")
+ (base32
+ "13mrihyid25h70800ix0mbqhs8dbi39nyif8f12mj54jpfdjhxcz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/rviewport")
+ (synopsis "Relative viewport for graphics inclusion")
+ (description
+ "Package @code{graphicx} provides a useful keyword viewport which allows
+to show just a part of an image. However, one needs to put there the actual
+coordinates of the viewport window. Sometimes it is useful to have relative
+coordinates as fractions of natural size. For example, one may want to print
+a large image on a spread, putting a half on a verso page, and another half on
+the next recto page. For this one would need a viewport occupying exactly one
+half of the file's bounding box, whatever the actual width of the image may
+be. This package adds a new keyword @code{rviewport} to the @code{graphicx}
+package specifiying relative viewport for graphics inclusion: a window defined
+by the given fractions of the natural width and height of the image.")
+ (license license:lppl)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")