aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:42:24 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:17:02 +0100
commit9af8ed27daa43cdddec2fdd6d8c542f7a938c81a (patch)
treecb3c9d95d0dfd843a0ef7a08f692a84e8e625ca6
parenta6907b0da0c680d216b460bfcc35b1263cb1c86d (diff)
downloadguix-9af8ed27daa43cdddec2fdd6d8c542f7a938c81a.tar.gz
guix-9af8ed27daa43cdddec2fdd6d8c542f7a938c81a.zip
gnu: Add perl-package-variant.
* gnu/packages/perl.scm (perl-package-variant): New variable. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/perl.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 98c9d2b242..b473b742ef 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9139,6 +9139,36 @@ default if it's installed, and should be preferred in all environments with a
compiler.")
(license (package-license perl))))
+(define-public perl-package-variant
+ (package
+ (name "perl-package-variant")
+ (version "1.003002")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MS/MSTROUT/Package-Variant-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1p1n2ny5fb15bcbykyn523w6sv968gqs7nhjfm36dpac5yfq9vdj"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-moo perl-test-fatal perl-test-most))
+ (propagated-inputs (list perl-carp
+ perl-import-into
+ perl-module-runtime
+ perl-strictures-2))
+ (home-page "https://metacpan.org/release/Package-Variant")
+ (synopsis "Parameterizable packages")
+ (description
+ "This module allows you to build a variable package that contains a
+package template and can use it to build variant packages at runtime. Your
+variable package will export a subroutine which will build a variant package,
+combining its arguments with the template, and return the name of the new
+variant package. The implementation does not care about what kind of packages
+it builds, be they simple function exporters, classes, singletons or something
+else.")
+ (license license:perl-license)))
+
(define-public perl-padwalker
(package
(name "perl-padwalker")