aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-11-12 14:18:43 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-11-12 17:41:38 +0900
commit98e470d0a5c58dcdae35846de20a18a4916d9d9c (patch)
treec293ce433dd611586656cbaedf0e79f372588b82
parentbadcd4a79fb2f258ea817c680eb3bbaaf6d6f74c (diff)
downloadguix-98e470d0a5c58dcdae35846de20a18a4916d9d9c.tar.gz
guix-98e470d0a5c58dcdae35846de20a18a4916d9d9c.zip
gnu: yosys: Remove extraneous characters.
* gnu/packages/fpga.scm (yosys) [arguments]: Drop leading './' from file names. Drop leading '/' from file names given to 'search-input-file'. Change-Id: I49febe7bcf0d60553d2a24d99746e6457fa4d03f
-rw-r--r--gnu/packages/fpga.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 8d7b0a8dd1..c3b6030fb1 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -171,30 +171,29 @@ For synthesis, the compiler generates netlists in the desired format.")
#~(modify-phases %standard-phases
(add-before 'configure 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "./backends/smt2/smtio.py"
+ (substitute* "backends/smt2/smtio.py"
(("\\['z3")
- (string-append "['" (search-input-file inputs "/bin/z3"))))
- (substitute* "./kernel/fstdata.cc"
+ (string-append "['" (search-input-file inputs "bin/z3"))))
+ (substitute* "kernel/fstdata.cc"
(("vcd2fst")
- (search-input-file inputs "/bin/vcd2fst")))
- (substitute* '("./passes/cmds/show.cc"
- "./passes/cmds/viz.cc")
+ (search-input-file inputs "bin/vcd2fst")))
(substitute* "kernel/driver.cc"
(("^#include \"libs/cxxopts/include/cxxopts.hpp\"")
"#include <cxxopts.hpp>"))
+ (substitute* '("passes/cmds/show.cc"
+ "passes/cmds/viz.cc")
(("exec xdot")
- (string-append "exec " (search-input-file inputs
- "/bin/xdot")))
+ (string-append "exec " (search-input-file inputs "bin/xdot")))
(("dot -")
- (string-append (search-input-file inputs "/bin/dot") " -"))
+ (string-append (search-input-file inputs "bin/dot") " -"))
(("fuser")
- (search-input-file inputs "/bin/fuser")))))
+ (search-input-file inputs "bin/fuser")))))
(replace 'configure
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make" "config-gcc" make-flags)))
(add-after 'configure 'use-external-abc
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* '("./Makefile")
+ (substitute* '("Makefile")
(("ABCEXTERNAL \\?=")
(string-append "ABCEXTERNAL = "
(search-input-file inputs "/bin/abc"))))))