aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-08-30 00:14:03 +0900
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-23 20:26:17 +0100
commit98aed3b9f86dc7085d7c335aceccef88a3dda6b3 (patch)
tree780c6755baf320ba8d12b17f3290b6d8352b1a3d
parent41e408eb1f93d96b549d345e2de74143220b7b76 (diff)
downloadguix-98aed3b9f86dc7085d7c335aceccef88a3dda6b3.tar.gz
guix-98aed3b9f86dc7085d7c335aceccef88a3dda6b3.zip
gnu: Add go-zgo-at-runewidth.
* gnu/packages/golang-xyz.scm (go-zgo-at-runewidth): New variable. Change-Id: I7c03b7e89ba45e8ce63cc482a4f860bdf839f727 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 40fc2ce5f7..dc131f0065 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2024 Luis Higino <luishenriquegh2701@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7346,6 +7347,32 @@ also provides V-style logging controlled by the @code{-v} and
defined in @url{https://editorconfig.org/,https://editorconfig.org/}.")
(license license:bsd-3)))
+(define-public go-zgo-at-runewidth
+ (package
+ (name "go-zgo-at-runewidth")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arp242/runewidth")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17wbzwak831z04kj4xdvh2q78k3in3kay009n0yj8nlwn1p126ph"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "zgo.at/runewidth"))
+ (home-page "https://github.com/arp242/runewidth")
+ (synopsis "Get fixed width of the character or string")
+ (description
+ "@samp{runewidth} provides functions to get fixed width of the character
+or string. It is a fork of https://github.com/mattn/go-runewidth, updated to
+the newest Unicode and having various helper functions removed, so all that
+remains is just the @code{runewidth.RuneWidth()} function.")
+ (license license:expat)))
+
;;;
;;; Executables:
;;;