aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-17 15:54:57 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-17 23:43:58 +0900
commit933f2ca76acd8da03880569684cf10a4b3094a60 (patch)
tree6dbfa382c46dfaa726e503f9deb100c150151622
parentf04d44562fde5bb96d820e14dc7129c26d0a4bd8 (diff)
downloadguix-933f2ca76acd8da03880569684cf10a4b3094a60.tar.gz
guix-933f2ca76acd8da03880569684cf10a4b3094a60.zip
gnu: Add python-ndindex.
Adapted from <https://raw.githubusercontent.com/Blosc/python-blosc2/refs/heads/main/.guix/modules/python-blosc2-package.scm>. * gnu/packages/python-science.scm (python-ndindex): New variable. Co-authored-by: Ivan Vilata i Balaguer <ivan@selidor.net> Change-Id: I38fbcbd8859c2ddbfdd39e8d84a63b20deef75c4
-rw-r--r--gnu/packages/python-science.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 05c6ac1fc1..1aaf52d3f5 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1012,6 +1012,30 @@ Evapotranspiration using various standard methods.")
tissue-specificity metrics for gene expression.")
(license license:gpl3+)))
+(define-public python-ndindex
+ (package
+ (name "python-ndindex")
+ (version "1.7") ;newer versions require a newer numpy
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ndindex" version))
+ (sha256
+ (base32 "1lpgsagmgxzsas7g8yiv6wmyss8q57w92h70fn11rnpadsvx16xz"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:test-flags #~(list "-c" "/dev/null"))) ;avoid coverage
+ (native-inputs
+ (list python-cython
+ python-numpy
+ python-pytest
+ python-setuptools
+ python-wheel))
+ (home-page "https://quansight-labs.github.io/ndindex/")
+ (synopsis "Python library for manipulating indices of ndarrays")
+ (description "This package provides a Python library for manipulating
+indices of @code{ndarrays}.")
+ (license license:expat)))
+
(define-public python-pandas-1
(package
(name "python-pandas")