aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-11 13:46:10 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:40:28 +0300
commit922aa64695ac24246a9e794d1356ef0216c71875 (patch)
treefed531319ba150b71dd3096ac28ba56153703a86
parentfef7b2133bbc6daadf38a2a70443aafce150a946 (diff)
downloadguix-922aa64695ac24246a9e794d1356ef0216c71875.tar.gz
guix-922aa64695ac24246a9e794d1356ef0216c71875.zip
gnu: Add rust-gix-config-0.32.
* gnu/packages/crates-vcs.scm (rust-gix-config-0.32): New variable. (rust-gix-config-0.31): Inherit from rust-gix-config-0.32. Change-Id: I73649cd163d115f03579b8e78d668f502f42de44
-rw-r--r--gnu/packages/crates-vcs.scm38
1 files changed, 34 insertions, 4 deletions
diff --git a/gnu/packages/crates-vcs.scm b/gnu/packages/crates-vcs.scm
index acadd70f90..0e7b534bac 100644
--- a/gnu/packages/crates-vcs.scm
+++ b/gnu/packages/crates-vcs.scm
@@ -1128,17 +1128,17 @@ package provides read only access to git commitgraph file.")
("rust-serde" ,rust-serde-1)
("rust-thiserror" ,rust-thiserror-1))))))
-(define-public rust-gix-config-0.31
+(define-public rust-gix-config-0.32
(package
(name "rust-gix-config")
- (version "0.31.0")
+ (version "0.32.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "gix-config" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1fzraij8rb98j71id939qc56nzaqfaqp8ln3kcvhjv66nk39ibjw"))))
+ (base32 "1hz0rj2nx16jrmp6sjzamk2wk96zcmq1s4lfp2c6wryqalflfh83"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
@@ -1147,7 +1147,7 @@ package provides read only access to git commitgraph file.")
("rust-gix-features" ,rust-gix-features-0.36)
("rust-gix-glob" ,rust-gix-glob-0.14)
("rust-gix-path" ,rust-gix-path-0.10)
- ("rust-gix-ref" ,rust-gix-ref-0.38)
+ ("rust-gix-ref" ,rust-gix-ref-0.39)
("rust-gix-sec" ,rust-gix-sec-0.10)
("rust-memchr" ,rust-memchr-2)
("rust-once-cell" ,rust-once-cell-1)
@@ -1164,6 +1164,36 @@ package provides read only access to git commitgraph file.")
is a pure Rust implementation of Git.")
(license (list license:expat license:asl2.0))))
+(define-public rust-gix-config-0.31
+ (package
+ (inherit rust-gix-config-0.32)
+ (name "rust-gix-config")
+ (version "0.31.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gix-config" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1fzraij8rb98j71id939qc56nzaqfaqp8ln3kcvhjv66nk39ibjw"))))
+ (arguments
+ `(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
+ ("rust-document-features" ,rust-document-features-0.2)
+ ("rust-gix-config-value" ,rust-gix-config-value-0.14)
+ ("rust-gix-features" ,rust-gix-features-0.36)
+ ("rust-gix-glob" ,rust-gix-glob-0.14)
+ ("rust-gix-path" ,rust-gix-path-0.10)
+ ("rust-gix-ref" ,rust-gix-ref-0.38)
+ ("rust-gix-sec" ,rust-gix-sec-0.10)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-smallvec" ,rust-smallvec-1)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-unicode-bom" ,rust-unicode-bom-2)
+ ("rust-winnow" ,rust-winnow-0.5))
+ #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.5))))))
+
(define-public rust-gix-config-0.30
(package
(inherit rust-gix-config-0.31)