aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2024-11-24 12:28:17 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-24 14:42:53 +0000
commit851f0662a5e7e65619564066f0995688e7ef9829 (patch)
tree4ac872b83e974e998e9fe1a5e85fce7e73535fdd
parent79510f5e6295342f864d21b38869d215ac99a213 (diff)
downloadguix-851f0662a5e7e65619564066f0995688e7ef9829.tar.gz
guix-851f0662a5e7e65619564066f0995688e7ef9829.zip
gnu: python-pycurl: Fix build by running the tests single-threaded.
* gnu/packages/python-web.scm (python-pycurl): Make test run single-threaded. Reenable some tests that used to fail due to threading. [test_request_without_certinfo]: Disable test/timebomb that probably uses an expired CA. Change-Id: I62bc60757cf2e005ed55768c84d8c178f63c35ec Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-web.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cf3c15857c..9bd6d10ef0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -68,6 +68,7 @@
;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Spencer King <spencer.king@geneoscopy.com>
+;;; Copyright © 2024 Attila Lendvai <attila@lendvai.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2026,15 +2027,17 @@ Amazon S3 compatible object storage server.")
(build-system pyproject-build-system)
(arguments
'(#:test-flags
- (list "--n" (number->string (parallel-job-count))
+ ;; The test suite is not thread safe, therefore --numprocesses 1:
+ ;; - some tests want to use the same port: address already in use
+ ;; - some tests use signal.Signal, i.e. main-thread only
+ (list "--numprocesses" "1" ; (number->string (parallel-job-count))
"-k" (string-append
;; Disable hanginging tests
"not test_multi_socket_select"
;; E assert None is not None
;; E+ where None =
;; <tests.multi_callback_test.MultiCallbackTest
- ;; testMethod=test_easy_pause_unpause>.socket_result
- " and not test_easy_pause_unpause"
+ ;; testMethod=test_multi_socket_action>.timer_result
" and not test_multi_socket_action"
;; E pycurl.error: (1, '')
" and not test_http_version_3"
@@ -2047,9 +2050,8 @@ Amazon S3 compatible object storage server.")
;; OSError: tests/fake-curl/libcurl/with_openssl.so: cannot
;; open shared object file: No such file or directory
" and not test_libcurl_ssl_openssl"
- ;; pycurl.error: (56, 'Recv failure: Connection reset by
- ;; peer')
- " and not test_post_with_read_callback"))
+ ;; Probably due to an expired CA
+ " and not test_request_without_certinfo"))
#:phases (modify-phases %standard-phases
(add-before 'build 'configure-tls-backend
(lambda _