aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-02-18 22:02:57 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:42:23 +0300
commit83d170676cd6df29b9e107af550099c64bce982d (patch)
treef444242e3307ddc249753a229830f230c99de872
parent7318c216ce2fcb9d6ded8634b82d7451b6b2cbb0 (diff)
downloadguix-83d170676cd6df29b9e107af550099c64bce982d.tar.gz
guix-83d170676cd6df29b9e107af550099c64bce982d.zip
gnu: Add rust-http-range-header-0.4.
* gnu/packages/rust-apps.scm (rust-http-range-header-0.4): Add variable. (rust-http-range-header-0.3): Inherit rust-http-range-header-0.4. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-web.scm24
1 files changed, 19 insertions, 5 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 05cc9c4f37..65692183f8 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2795,17 +2795,17 @@ response bodies.")
(description "This package provides types and traits for HTTP clients.")
(license (list license:expat license:asl2.0))))
-(define-public rust-http-range-header-0.3
+(define-public rust-http-range-header-0.4
(package
(name "rust-http-range-header")
- (version "0.3.1")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "http-range-header" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "13vm511vq3bhschkw2xi9nhxzkw53m55gn9vxg7qigfxc29spl5d"))))
+ (base32 "1zhigmvyrk50jzll6nmn7n1rxkfzh8xn0838dvdvnj52rlqyzr1w"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-development-inputs
@@ -2814,10 +2814,24 @@ response bodies.")
("rust-quickcheck-macros" ,rust-quickcheck-macros-1)
("rust-regex" ,rust-regex-1))))
(home-page "https://github.com/MarcusGrass/parse-range-headers")
- (synopsis "No-dep range header parser")
- (description "This crate provides a no-dep range header parser.")
+ (synopsis "Zero-dependency range header parser")
+ (description "This package provides a range header parser without any
+dependencies.")
(license license:expat)))
+(define-public rust-http-range-header-0.3
+ (package
+ (inherit rust-http-range-header-0.4)
+ (name "rust-http-range-header")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "http-range-header" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "13vm511vq3bhschkw2xi9nhxzkw53m55gn9vxg7qigfxc29spl5d"))))))
+
(define-public rust-http-types-2
(package
(name "rust-http-types")