aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-08-04 22:15:50 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-06 11:46:24 +0200
commit8349d308069ef3d6803afa69f58eff74005232a2 (patch)
tree1471043b1a1fe53d1ed76b498dbb6ffe893435e4
parente85b3fc5956591199810643b1f75229ae92c20d5 (diff)
downloadguix-8349d308069ef3d6803afa69f58eff74005232a2.tar.gz
guix-8349d308069ef3d6803afa69f58eff74005232a2.zip
gnu: python-nbval: Update to 0.11.0.
* gnu/packages/python-check.scm (python-nbval): Update to 0.11.0. [arguments]<#:phases>: Adjust 'check' phase. [native-inputs]: Remove python-pytest. [propagated-inputs]: Add python-coverage and python-pytest. Remove python-six.
-rw-r--r--gnu/packages/python-check.scm27
1 files changed, 11 insertions, 16 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 88729df594..4888b42bc1 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1609,13 +1609,13 @@ notebooks.")
(define-public python-nbval
(package
(name "python-nbval")
- (version "0.9.6")
+ (version "0.11.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "nbval" version))
(sha256
- (base32 "0h3xrnw0mj1srigrx2rfnd73h8s0xjycclmjs0vx7qkfyqpcvvyg"))))
+ (base32 "154h6xpf9h6spgg3ax6k79fd40j197ipwnfjmf5rc2kvc2bmgjbp"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1629,21 +1629,16 @@ notebooks.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "-vv" "-k"
- (string-append
- ;; This only works with Pytest < 5.
- "not nbdime_reporter"
- ;; https://github.com/computationalmodelling/nbval/pull/148.
- " and not test_timeouts"
- ;; It seems the output format has changed; the following
- ;; test fails with "Unexpected output fields from
- ;; running code: {'text/plain'}".
- " and not test_conf_ignore_stderr "))))))))
- (native-inputs
- (list python-pytest python-pytest-cov python-sympy))
+ (invoke "pytest" "-vv"
+ ;; nbdime forms a dependency cycle
+ "--ignore=tests/test_nbdime_reporter.py")))))))
+ (native-inputs (list python-pytest-cov python-sympy))
(propagated-inputs
- (list python-ipykernel python-jupyter-client python-nbformat
- python-six))
+ (list python-coverage
+ python-ipykernel
+ python-jupyter-client
+ python-nbformat
+ python-pytest))
(home-page "https://github.com/computationalmodelling/nbval")
(synopsis "Pytest plugin to validate Jupyter notebooks")
(description