aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-12-22 17:26:51 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-01-01 13:05:04 +0100
commit7bc6ec189e2268888ef823f4e94a177fa72b81f1 (patch)
tree6b21cf5441efcb9160b6901fd63baa805c47c577
parent0de2caa2a2686e70cb8150c17d64d0e160bdb1a7 (diff)
downloadguix-7bc6ec189e2268888ef823f4e94a177fa72b81f1.tar.gz
guix-7bc6ec189e2268888ef823f4e94a177fa72b81f1.zip
gnu: Add sympow.
* gnu/packages/maths.scm (sympow): New variable. Change-Id: Iaeaea352f0a3a65a877b2845ecdc18856ded6d3c Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/maths.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f6694a4ebb..60ab9ae5cb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -158,6 +158,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages m4)
+ #:use-module (gnu packages man)
#:use-module (gnu packages mpi)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
@@ -898,6 +899,45 @@ of linear equations, computes extreme rays of polyhedral cones, solves
integer programming problems and computes Markov bases for statistics.")
(license license:gpl2+)))
+(define-public sympow
+ (package
+ (name "sympow")
+ (version "2.023.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/rezozer/forks/sympow")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ilnxygkj4g5arjiyd16k00cvnjlqs0cpc8hk64kbqhl877mm5i9"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; no tests
+ #:phases #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Configure"
+ (("/bin/sh") (search-input-file inputs "/bin/bash")))
+ (setenv "PREFIX" #$output)
+ (setenv "VARPREFIX" #$output)
+ (invoke "bash" "./Configure"))))))
+ (native-inputs (list bash-minimal coreutils help2man pari-gp which))
+ (home-page "https://gitlab.com/rezozer/forks/sympow")
+ (synopsis "Symmetric power elliptic curve L-functions")
+ (description "SYMPOW is a mathematical program to compute special values
+of symmetric power elliptic curve L-functions; it can compute up to about 64
+digits of precision.")
+ ;; bsd-2 with extra stipulation that users be informed of sympow's
+ ;; "less restrictive license" if it's included in a program with a more
+ ;; restrictive license. However, since sympow includes fpu.c which is
+ ;; gpl2+ the whole package can only be distributed via GPL anyway.
+ ;; See also <https://gitlab.com/rezozer/forks/sympow/-/issues/7>.
+ (license (license:non-copyleft "file:///COPYING"
+ "See COPYING in the distribution."))))
+
(define-public cddlib
(package
(name "cddlib")