aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-09-28 19:11:39 +0200
committerAndreas Enge <andreas@enge.fr>2024-12-03 10:45:38 +0100
commit6fcafbae0c90e771175eee49ae756a03228cc4b7 (patch)
tree71637b433350b9129a56f4061ada3fe0d4c80752
parent2ef05f033cc83e57aa375262dcf98c2a3da8b770 (diff)
downloadguix-6fcafbae0c90e771175eee49ae756a03228cc4b7.tar.gz
guix-6fcafbae0c90e771175eee49ae756a03228cc4b7.zip
gnu: gsl: Build with ‘-O2 -g’ unconditionally.
Fixes a regression introduced in 53bec65c51c3f2b7e318db4dc7a5c3a09ad00214 that would cause gsl to be built without optimizations and without debugging symbols (equivalent to “-O0 -g0”). * gnu/packages/maths.scm (gsl)[arguments]: Remove #:make-flags. Change-Id: I5297e3602bffbb7655d655622cc3d7595f82b25a
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 84918c78d2..e835ad36d6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -688,17 +688,7 @@ precision floating point numbers.")
(outputs '("out" "static" "debug"))
(build-system gnu-build-system)
(arguments
- (list ;; FIXME: Setting CFLAGS=-fPIC is not only unnecessary, it's also
- ;; harmful because it removes the default '-O2 -g', meaning that the
- ;; library ends up being compiled as -O0. Consequently, some
- ;; numerical tests fail, notably on i686-linux. TODO: Remove
- ;; 'CFLAGS=-fPIC' for all systems and revisit or remove
- ;; 'disable-failing-tests' phases accordingly.
- #:make-flags (if (and (not (%current-target-system))
- (string=? (%current-system) "i686-linux"))
- #~'()
- #~(list "CFLAGS=-fPIC"))
- #:phases
+ (list #:phases
#~(modify-phases %standard-phases
#$@(cond
((and (target-riscv64?)