aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-31 16:17:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:22:14 +0200
commit6c27de6ebe9b6dce96c2dc667f467c7faea02f43 (patch)
treeee7963141add4c9e6ca51f1bd998e1a684590401
parent410b62425dde90d478d0603a63f3b5c0dfb00eae (diff)
downloadguix-6c27de6ebe9b6dce96c2dc667f467c7faea02f43.tar.gz
guix-6c27de6ebe9b6dce96c2dc667f467c7faea02f43.zip
gnu: Remove rust-crypto-hash-0.3.
* gnu/packages/crates-crypto.scm (rust-crypto-hash-0.3): Delete variable. Change-Id: I5b1e3940b18111a7810221e944309e6f6f8d22d6
-rw-r--r--gnu/packages/crates-crypto.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index f4155c825c..2450572f57 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1514,34 +1514,6 @@ of cryptographic primitives.")
;; The user can choose either license.
(license (list license:expat license:asl2.0))))
-(define-public rust-crypto-hash-0.3
- (package
- (name "rust-crypto-hash")
- (version "0.3.4")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "crypto-hash" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1jnxgpk0j29hzcv42viq5dckyfjnxdjsar55366j95zx80i1cxwa"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-commoncrypto" ,rust-commoncrypto-0.2)
- ("rust-hex" ,rust-hex-0.3)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-winapi" ,rust-winapi-0.3))))
- (inputs
- (list openssl))
- (home-page "https://github.com/malept/crypto-hash")
- (synopsis "Wrapper for OS-level cryptographic hash functions")
- (description "This package provides a wrapper for OS-level cryptographic
-hash functions.")
- (license license:expat)))
-
(define-public rust-crypto-mac-0.11
(package
(name "rust-crypto-mac")