aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-04-23 23:39:32 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-04-23 23:39:32 -0400
commit6b9e3f0dd1ea68204c960badae2a11489d1f029f (patch)
tree11a5898fd4fd95eb23a2e4609591b58cfebd695e
parenta70e9378cd62c0f757ed747db30eb2730cb627ce (diff)
downloadguix-6b9e3f0dd1ea68204c960badae2a11489d1f029f.tar.gz
guix-6b9e3f0dd1ea68204c960badae2a11489d1f029f.zip
gnu: python-configargparse: Update to 1.5.3.
* gnu/packages/python-xyz.scm (python-configargparse): Update to 1.5.3. [build-system]: Switch to pyproject-build-system. [arguments]: Remove previous 'check' phase. [native-inputs]: Add python-mock and python-pytest, remove python-pyyaml.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 4 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bfaef9e990..bc1360c000 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14793,28 +14793,16 @@ consistent API regardless of how the configuration was created.")
(define-public python-configargparse
(package
(name "python-configargparse")
- (version "1.2.3")
+ (version "1.5.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "ConfigArgParse" version))
(sha256
(base32
- "1p1pzpf5qpf80bfxsx1mbw9blyhhypjvhl3i60pbmhfmhvlpplgd"))))
- (build-system python-build-system)
+ "17vky4ihicbf7nggg30xs7h3g5rxzwgch8vilnnrvdaacszkq2qv"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pyyaml))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- ;; Bypass setuptools-shim because one test relies on "setup.py"
- ;; being the first argument passed to the python call.
- ;;
- ;; NOTE: Many tests do not run because they rely on Python's
- ;; built-in test.test_argparse, but we remove the unit tests from
- ;; our Python installation.
- (invoke "python" "setup.py" "test"))))))
+ (list python-mock python-pytest))
(synopsis "Replacement for argparse")
(description "A drop-in replacement for argparse that allows options to also
be set via config files and/or environment variables.")