aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:04:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:06 +0200
commit6902250a949ba2862d95272e890661cf7ba7bb84 (patch)
treec63f6a2329744d22613fcc4a567507214fe78709
parent404c4259d13b95661241aad95d36cd71130fa2f8 (diff)
downloadguix-6902250a949ba2862d95272e890661cf7ba7bb84.tar.gz
guix-6902250a949ba2862d95272e890661cf7ba7bb84.zip
gnu: Add texlive-attachfile2.
* gnu/packages/tex.scm (texlive-attachfile2): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6733d78f83..148ab0c234 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2346,6 +2346,33 @@ a per-attachment basis. @code{attachfile} makes it easy to attach files and
customize their appearance in the enclosing document.")
(license license:lppl1.3+)))
+(define-public texlive-attachfile2
+ (package
+ (name "texlive-attachfile2")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/attachfile2/"
+ "doc/man/man1/pdfatfi.1"
+ "doc/man/man1/pdfatfi.man1.pdf"
+ "scripts/attachfile2/"
+ "source/latex/attachfile2/"
+ "tex/latex/attachfile2/")
+ (base32
+ "14glnfyp58ka78l5kc09mc96km7jd77qvsby0p8dpjhvwf6qfzg8")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "pdfatfi.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/attachfile2")
+ (synopsis "Attach files into PDF")
+ (description
+ "This package can be used to attach files to a PDF document. It is
+a further development of Scott Pakin's package @code{attachfile} for pdfTeX.
+Apart from bug fixes, this package adds support for dvips, some new options,
+and gets and writes meta information data about the attached files.")
+ (license license:lppl1.3c)))
+
(define-public texlive-atveryend
(package
(name "texlive-atveryend")