aboutsummaryrefslogtreecommitdiff
diff options
context:
2013-02-16Replace individual scripts with master 'guix' script....Mark H Weaver
2013-01-06Update license headers....Ludovic Courtès
2012-11-13guix-download: Use code from (guix build download)....Ludovic Courtès
2012-11-13guix-download: Add support for file:// URIs....Ludovic Courtès
2012-11-13guix-download: Gracefully handle invalid URIs....Ludovic Courtès
2012-11-08guix-download: Error out when the HTTP response code is not 200....Ludovic Courtès
    Add python-poyo.
    * gnu/packages/python-xyz.scm (python-poyo): New public variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
    Diffstat
    -rw-r--r--gnu/packages/python-xyz.scm21
    1 files changed, 21 insertions, 0 deletions
    diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
    index f924aafc92..145de90d8e 100644
    --- a/gnu/packages/python-xyz.scm
    +++ b/gnu/packages/python-xyz.scm
    @@ -1572,6 +1572,27 @@ existing ones.")
    ;; Tests don't work with python2.
    #:tests? #f)))))
    +(define-public python-poyo
    + (package
    + (name "python-poyo")
    + (version "0.5.0")
    + (source
    + (origin
    + (method url-fetch)
    + (uri (pypi-uri "poyo" version))
    + (sha256
    + (base32
    + "1pflivs6j22frz0v3dqxnvc8yb8fb52g11lqr88z0i8cg2m5csg2"))))
    + (build-system python-build-system)
    + (home-page "https://github.com/hackebrot/poyo")
    + (synopsis "Lightweight YAML Parser for Python")
    + (description
    + "This package provides a lightweight YAML Parser for Python. It supports
    +only a chosen subset of the YAML format that is required to parse cookiecutter
    +user configuration files. It does not have support for serializing into YAML
    +and is not compatible with JSON.")
    + (license license:expat)))
    +
    (define-public scons
    (package
    (name "scons")