aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:28 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:51 +0000
commit652e7578ce84829246548f03e587ab3a3767f2cc (patch)
tree51d81723783825063bfe073ebfe013190ce2c86b
parent9be29a2462564fbd0f5e866110b50519ccd7823a (diff)
downloadguix-652e7578ce84829246548f03e587ab3a3767f2cc.tar.gz
guix-652e7578ce84829246548f03e587ab3a3767f2cc.zip
gnu: python-pytest-runner: Improve package style.
* gnu/packages/check.scm (python-pytest-runner): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Remove check phase replacement. Update <#:tests?> refusal comment. [native-inputs]: Add python-pip, python-pypa-build, python-setuptools and python-wheel. Change-Id: Id36e7ed4a3cec6098f0877f48f3fbcbd8007f3c3 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/check.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 75ef0aa9f2..8e866c34c6 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1994,10 +1994,10 @@ Python's @code{random.seed}.")
(sha256
(base32
"11dnhxnjmh4nf1j8rnvx944ha3wg8ggrgrwdcx4c7d19xmi57n5l"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
- ;; FIXME: The test suite requires 'python-flake8' and 'python-black',
+ ;; FIXME: The test suite requires 'python-pytest-virtualenv',
;; but that introduces a circular dependency.
#:tests? #f
#:phases
@@ -2011,14 +2011,10 @@ Python's @code{random.seed}.")
(lambda _
(let ((whl (car (find-files "dist" "\\.whl$"))))
(invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-vv")
- (format #t "test suite not run~%")))))))
+ "install" "--no-deps" "--prefix" #$output whl)))))))
(native-inputs
- (list python-pypa-build python-setuptools-scm python-wheel))
+ (list python-pip python-pypa-build python-pytest
+ python-setuptools python-setuptools-scm python-wheel))
(home-page "https://github.com/pytest-dev/pytest-runner")
(synopsis "Invoke py.test as a distutils command")
(description