aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2025-02-09 19:49:00 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-14 14:03:16 +0000
commit5c9572a5e60d7e91ba5b182b1a80fc9ce42846a7 (patch)
tree5d32288f97d0603727274264029178d58e48192d
parent3a916935311568b742d734cf76be8a45737f9382 (diff)
downloadguix-5c9572a5e60d7e91ba5b182b1a80fc9ce42846a7.tar.gz
guix-5c9572a5e60d7e91ba5b182b1a80fc9ce42846a7.zip
gnu: Add go-github-com-jphastings-jwker.
* gnu/packages/golang-crypto.scm (go-github-com-jphastings-jwker, go-jwker): New variables. Change-Id: Iffc746524f2cd4461ae7f204cb8c82136b63d21d Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-crypto.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index edfe26b454..fa8c5e9529 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -24,6 +24,8 @@
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Jean Simard <woshilapin@tuziwo.info>
;;; Copyright © 2024 Superfly Johnson <superfly.johnson@yahoo.com>
+;;; Copyright © 2025 Roman Scherer <roman@burningswell.com>
+;;; Copyright © 2025 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1259,6 +1261,33 @@ Stealing encryption and decryption methods.")
"A Golang library to verify Minisign signatures.")
(license license:expat)))
+(define-public go-github-com-jphastings-jwker
+ (package
+ (name "go-github-com-jphastings-jwker")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jphastings/jwker")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nb487c2cfazxwqghq5a8iz8gyi0hhajc39c260f0n6d3ib1798g"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jphastings/jwker"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/jphastings/jwker")
+ (synopsis "PEM -> JWK conversion tool")
+ (description
+ "This package implements a functionality to convert keys between the
+@acronym{PEM, Privacy-Enhanced Mail} and @acronym{JWK, JSON Web Key} file
+formats.")
+ (license license:expat)))
+
(define-public go-github-com-jzelinskie-whirlpool
(package
(name "go-github-com-jzelinskie-whirlpool")
@@ -2565,6 +2594,19 @@ Go.")
#:unpack-path "filippo.io/age"
#:install-source? #f))))
+(define-public go-jwker
+ (package/inherit go-github-com-jphastings-jwker
+ (name "go-jwker")
+ (arguments
+ (list
+ #:tests? #f
+ #:install-source? #f
+ #:build-flags
+ #~(list (string-append "-ldflags=-X main.version="
+ #$(package-version this-package)))
+ #:unpack-path "github.com/jphastings/jwker"
+ #:import-path "github.com/jphastings/jwker/cmd/jwker"))))
+
(define-public go-keyring
(package
(inherit go-github-com-99designs-keyring)