aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-08 21:10:46 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:24 -0400
commit5c35c65bde03da32a6203530b9456c50aa19d02c (patch)
tree3af13369bf15ce93f17f78e2a67572f9f79bc8e7
parentccddc7c19fe83206ff7916902349d335bbdc744f (diff)
downloadguix-5c35c65bde03da32a6203530b9456c50aa19d02c.tar.gz
guix-5c35c65bde03da32a6203530b9456c50aa19d02c.zip
gnu: Add ruby-ruby2-keywords.
* gnu/packages/ruby.scm (ruby-ruby2-keywords): New variable.
-rw-r--r--gnu/packages/ruby.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5b3e8fa4fe..210a456432 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10644,6 +10644,41 @@ more robust and work for non rails projects.")
(home-page "https://github.com/danmayer/code_statistics")
(license license:expat)))
+(define-public ruby-ruby2-keywords
+ (package
+ (name "ruby-ruby2-keywords")
+ (version "0.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ruby/ruby2_keywords")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jhqb152zfr2yrxj6j8rzakkwdkg5viggwnnqrrfxwwy63msdi97"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'delete-extraneous-rake-files
+ (lambda _
+ (for-each delete-file '("rakelib/changelogs.rake"
+ "rakelib/epoch.rake"
+ "rakelib/version.rake"))))
+ (add-after 'extract-gemspec 'adjust-files
+ (lambda _
+ (substitute* "ruby2_keywords.gemspec"
+ ;; This file is not present in the git checkout.
+ ((".*\"ChangeLog\",.*") "")))))))
+ (synopsis "Shim library for Module#ruby2_keywords")
+ (description "Provides empty @code{Module#ruby2_keywords} method, for the
+forward source-level compatibility against @command{ruby2.7} and
+@command{ruby3}.")
+ (home-page "https://github.com/ruby/ruby2_keywords")
+ (license license:bsd-2)))
+
(define-public ruby-rubypants
(package
(name "ruby-rubypants")