aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-11 11:50:10 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:48 +0200
commit5b3e996d2980cf6549264ae111f36598efc91114 (patch)
treee7d293632e011fe8b7670ed424ecaca0d23c69d9
parent3729099184d80119212bf707d0001b976e3b755e (diff)
downloadguix-5b3e996d2980cf6549264ae111f36598efc91114.tar.gz
guix-5b3e996d2980cf6549264ae111f36598efc91114.zip
build-system/gnu: Change default locale to C.UTF-8.
This is a followup to 1cebc334a77030c0c94955981652f4df7608c9e3. * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): #:locale now defaults to "C.UTF-8". * guix/build/gnu-build-system.scm (install-locale): Likewise. * gnu/packages/linux.scm (util-linux)[arguments]: In ‘pre-check’ phase, remove ‘invalid-multibyte’ modification so the test runs under C.UTF-8. Change-Id: I9a4bfe564bcd8bbd0d57ba04568eb6b8020bd051
-rw-r--r--gnu/packages/linux.scm6
-rw-r--r--guix/build-system/gnu.scm4
-rw-r--r--guix/build/gnu-build-system.scm2
3 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index df8cc1943d..582e4ce88a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2281,11 +2281,7 @@ deviation, and minimum and maximum values. It can show a nice histogram too.")
;; Change the test to refer to the right file.
(substitute* "tests/ts/misc/mcookie"
(("/etc/services")
- services))
-
- ;; The C.UTF-8 locale does not exist in our libc.
- (substitute* "tests/ts/column/invalid-multibyte"
- (("C\\.UTF-8") "en_US.utf8")))))
+ services)))))
(add-before 'check 'disable-setarch-test
(lambda _
;; The setarch tests are unreliable in QEMU's user-mode
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index 55e254a418..2fa3506c54 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -361,7 +361,7 @@ standard packages used as implicit inputs of the GNU build system."
(make-dynamic-linker-cache? #t)
(license-file-regexp %license-file-regexp)
(phases '%standard-phases)
- (locale "en_US.utf8")
+ (locale "C.UTF-8")
(system (%current-system))
(build (nix-system->gnu-triplet system))
(imported-modules %default-gnu-imported-modules)
@@ -504,7 +504,7 @@ is one of `host' or `target'."
(license-file-regexp %license-file-regexp)
(phases '%standard-phases)
- (locale "en_US.utf8")
+ (locale "C.UTF-8")
(system (%current-system))
(build (nix-system->gnu-triplet system))
(imported-modules %default-gnu-imported-modules)
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index ef5873d793..39707e7ace 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -123,7 +123,7 @@ there are none."
native-search-paths)))
(define* (install-locale #:key
- (locale "en_US.utf8")
+ (locale "C.UTF-8")
(locale-category LC_ALL)
#:allow-other-keys)
"Try to install LOCALE; emit a warning if that fails. The main goal is to