aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-02-25 08:55:38 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-25 12:21:03 +0000
commit5ab81d5c281653b280d8081fc663540148f85d20 (patch)
tree1144292fc92d50ec4fd95d0eeb5b63f508f0297c
parentac9543ea79a481d549ab2564eb5f6ad86ecf9ef3 (diff)
downloadguix-5ab81d5c281653b280d8081fc663540148f85d20.tar.gz
guix-5ab81d5c281653b280d8081fc663540148f85d20.zip
gnu: python-pytest-sanic: Fix build.
* gnu/packages/python-check.scm (python-pytest-sanic) [build-system]: Swap to pyproject-build-system. [arguments] <phases>: Remove 'relax-requirements, add 'use-poetry-core. [native-inputs]: Add python-poetry-core. Change-Id: I13d44b4e57a96e304ba50fdf0c5e4948a2119f1d
-rw-r--r--gnu/packages/python-check.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2438a5938f..0beec6267d 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2814,20 +2814,20 @@ help in debugging failures and optimizing the scheduler to improve speed.")
(sha256
(base32
"0shq1bqnydj0l3ipb73j1qh5kqcjvzkps30zk8grq3dwmh3wmnkr"))))
- ;; We don't use pyproject-build-system because that would require
- ;; poetry.masonry.
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
;; Tests depend on python-sanic.
(list
#:tests? #f
#:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "setup.py"
- (("websockets.*<11.0")
- "websockets<13.0")))))))
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'use-poetry-core
+ (lambda _
+ ;; Patch to use the core poetry API.
+ (substitute* "pyproject.toml"
+ (("poetry.masonry.api") "poetry.core.masonry.api")))))))
+ (native-inputs
+ (list python-poetry-core))
(propagated-inputs
(list python-httpx python-async-generator python-pytest
python-websockets))