aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-15 23:53:28 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:14 -0400
commit59deb3878a7db700736da25c69eb2a7373d09248 (patch)
treea1a51162bd908a8f7a514bd6bed1c90802a9c0a6
parent5106860692827153c1dd927c0477f92f023bcc40 (diff)
downloadguix-59deb3878a7db700736da25c69eb2a7373d09248.tar.gz
guix-59deb3878a7db700736da25c69eb2a7373d09248.zip
gnu: python-hatchling: Move to (gnu packages python-build).
* gnu/packages/python-xyz.scm (python-hatchling): Move to... * gnu/packages/python-build.scm (python-hatchling): ... here.
-rw-r--r--gnu/packages/python-build.scm47
-rw-r--r--gnu/packages/python-xyz.scm45
2 files changed, 46 insertions, 46 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 161d334051..16a47f151a 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2018, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020, 2021, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
@@ -637,3 +637,48 @@ installed, will expose packages in a local directory on @code{sys.path} in
``editable mode''. In other words, changes to the package source will be
reflected in the package visible to Python, without needing a reinstall.")
(license license:expat)))
+
+(define-public python-hatchling
+ (package
+ (name "python-hatchling")
+ (version "1.13.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hatchling" version))
+ (sha256
+ (base32
+ "1isk1kqra0sm2sj2yp39sgk62mx0bp1jnbkwdcl3a1vjrji7blpq"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #false ;there are none
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-depend-on-hatchling
+ (lambda _
+ ;; We don't use hatchling.
+ (delete-file "pyproject.toml")
+ (call-with-output-file "pyproject.toml"
+ (lambda (port)
+ (format port "\
+[build-system]
+build-backend = 'setuptools.build_meta'
+requires = ['setuptools']
+")))
+ (call-with-output-file "setup.cfg"
+ (lambda (port)
+ (format port "\
+[metadata]
+name = hatchling
+version = '~a' " #$version))))))))
+ (propagated-inputs
+ (list python-editables
+ python-importlib-metadata
+ python-packaging
+ python-pathspec
+ python-pluggy
+ python-tomli))
+ (home-page "https://pypi.org/project/hatchling/")
+ (synopsis "Extensible Python build backend")
+ (description "Hatchling is an extensible Python build backend.")
+ (license license:expat)))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a595ec3a21..7a1edd82fd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1761,51 +1761,6 @@ compositions like @code{XOR} and @code{NAND} are emulated on top of them.
Expressions are constructed from parsed strings or directly in Python.")
(license license:bsd-2)))
-(define-public python-hatchling
- (package
- (name "python-hatchling")
- (version "1.13.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "hatchling" version))
- (sha256
- (base32
- "1isk1kqra0sm2sj2yp39sgk62mx0bp1jnbkwdcl3a1vjrji7blpq"))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:tests? #false ;there are none
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'do-not-depend-on-hatchling
- (lambda _
- ;; We don't use hatchling.
- (delete-file "pyproject.toml")
- (call-with-output-file "pyproject.toml"
- (lambda (port)
- (format port "\
-[build-system]
-build-backend = 'setuptools.build_meta'
-requires = ['setuptools']
-")))
- (call-with-output-file "setup.cfg"
- (lambda (port)
- (format port "\
-[metadata]
-name = hatchling
-version = '~a' " #$version))))))))
- (propagated-inputs
- (list python-editables
- python-importlib-metadata
- python-packaging
- python-pathspec
- python-pluggy
- python-tomli))
- (home-page "https://pypi.org/project/hatchling/")
- (synopsis "Extensible Python build backend")
- (description "Hatchling is an extensible Python build backend.")
- (license license:expat)))
-
(define-public python-hdf4
(package
(name "python-hdf4")