aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-02 11:46:17 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:13 -0400
commit4fda0fbda2aea6971b4cf1c7697f7062cbcdbceb (patch)
tree9bc143e2fdc3f9d22b296f3457ebc05c8c1ebc2b
parent65996e28172e1ea1392fd2ab2732f2c3e616f2a7 (diff)
downloadguix-4fda0fbda2aea6971b4cf1c7697f7062cbcdbceb.tar.gz
guix-4fda0fbda2aea6971b4cf1c7697f7062cbcdbceb.zip
gnu: Add ruby-dalli.
* gnu/packages/ruby.scm (ruby-dalli): New variable.
-rw-r--r--gnu/packages/ruby.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1237c41319..e914bd35e1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4918,6 +4918,41 @@ run as a daemon and to be controlled by simple start/stop/restart commands.")
(home-page "https://github.com/thuehlinger/daemons")
(license license:expat)))
+(define-public ruby-dalli
+ (package
+ (name "ruby-dalli")
+ (version "3.2.4")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/petergoldstein/dalli")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hhqqv1j3zd2y0vr6maaabsflrvkf1x0i6z8n725mhqydp3f9gwp"))))
+ (build-system ruby-build-system)
+ ;; Disable tests to avoid a dependency cycle with ruby-activesupport,
+ ;; through ruby-ruby-prof.
+ (arguments (list #:tests? #f))
+ (synopsis "High performance memcached client for Ruby")
+ (description "Dalli is a high performance pure Ruby client for accessing
+memcached servers. Dalli supports:
+
+@itemize
+@item Simple and complex memcached configurations
+@item Fail-over between memcached instances
+@item Fine-grained control of data serialization and compression
+@item Thread-safe operation
+@item SSL/TLS connections to memcached
+@item SASL authentication.
+@end itemize
+
+The name is a variant of Salvador Dali for his famous painting The Persistence
+of Memory.")
+ (home-page "https://github.com/petergoldstein/dalli")
+ (license license:expat)))
+
(define-public ruby-data_uri
(package
(name "ruby-data_uri")