aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-17 15:12:23 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:54 +0530
commit4e5d041c55d1dbefbde2ae442dc4d7ecaa30eeab (patch)
tree0c76190c2fbbeecf6ce1feddf45b74583eea3c05
parentc08fe8a9065aa14841380e96e7e3faacbc0cd156 (diff)
downloadguix-4e5d041c55d1dbefbde2ae442dc4d7ecaa30eeab.tar.gz
guix-4e5d041c55d1dbefbde2ae442dc4d7ecaa30eeab.zip
gnu: Add rust-ipnetwork-0.17.
* gnu/packages/crates-io.scm (rust-ipnetwork-0.17): New variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a7abfdf3a0..c8e80d6f8d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11633,6 +11633,32 @@ The module only uses stable feature so it is guaranteed to compile using the
stable toolchain.")
(license (list license:expat license:asl2.0))))
+(define-public rust-ipnetwork-0.17
+ (package
+ (name "rust-ipnetwork")
+ (version "0.17.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ipnetwork" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0sviri9ksb3cmhx3h0rcfy8pvpx7f0cx5ba1z87ydvf07amymhq2"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-serde" ,rust-serde-1))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.3)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1))))
+ (home-page "https://crates.io/crates/ipnetwork")
+ (synopsis "Work with IP CIDRs in Rust")
+ (description "This package provides a library to work with IP CIDRs in
+Rust.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-is-executable
(package
(name "rust-is-executable")