aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-29 23:59:02 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 15:43:10 +0100
commit4dc9cd218dc089eb11ce1390a9db16849e957f8d (patch)
tree1a9f6b0addce3cdf7027d108ab9018e8b801f51b
parentb60f731c68548e752195c7f9405756ca9f3e6ed5 (diff)
downloadguix-4dc9cd218dc089eb11ce1390a9db16849e957f8d.tar.gz
guix-4dc9cd218dc089eb11ce1390a9db16849e957f8d.zip
gnu: go-github-com-hashicorp-golang-lru-v2: Delete submodule.
The submodule <github.com/hashicorp/golang-lru/arc/v2> needs to be packed as dedicated package. It would easy the job for the importer as it contains it's own go.mod file. * gnu/packages/golang-xyz.scm (go-github-com-hashicorp-golang-lru-v2) [source]: Delete "arc" submodule. Change-Id: Iaace717e530e49a2c910ac6e78f3f2fec3a2b7ca
-rw-r--r--gnu/packages/golang-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5e66c9e082..82f95314c2 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3216,7 +3216,16 @@ Groupcache.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0lb2ylv2bz6lsqhn6c2hsafjjcx0hsdbah6arhb778g3xbkpgvf3"))))
+ (base32 "0lb2ylv2bz6lsqhn6c2hsafjjcx0hsdbah6arhb778g3xbkpgvf3"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Submodule(s) with their own go.mod files and packed as
+ ;; separated packages:
+ ;;
+ ;; - github.com/hashicorp/golang-lru/arc/v2
+ (for-each delete-file-recursively
+ (list "arc"))))))
(build-system go-build-system)
(arguments
(list