aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2024-11-23 17:58:51 +0100
committerLudovic Courtès <ludo@gnu.org>2024-11-25 11:40:54 +0100
commit498b6cd008f1989b7cfda060d8a6790015eb2340 (patch)
tree1b91542431a8a8c0c891971281d5bf93ba2b5754
parent9f0f3a7eebbecce4768b9876c4cf6bb9fa4ce6c3 (diff)
downloadguix-498b6cd008f1989b7cfda060d8a6790015eb2340.tar.gz
guix-498b6cd008f1989b7cfda060d8a6790015eb2340.zip
gnu: Add python-protobuf-5.
* gnu/packages/protobuf.scm (python-protobuf-5): New variable. Change-Id: Ic181a92bc0e3eb66adf535d98b192cbb006028ad Signed-off-by: Luca Matei Pintilie <luca@lucamatei.com> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/protobuf.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index b8679eff25..59f49c8cf4 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -436,6 +436,39 @@ from protobuf specification files.")
(propagated-inputs (list python-protobuf))
(synopsis "Small code-size Protocol Buffers implementation in Python")))
+(define-public python-protobuf-5
+ (package
+ (name "python-protobuf")
+ (version "5.27.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "protobuf" version))
+ (sha256
+ (base32
+ "0b6qxb6hnhzmiz1wnjrjdmwxx2ddv9zr86p89vivgwj0wq1hjil2"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; FIXME: ImportError: 'testing_refleaks' module incorrectly imported from
+ ;; '/gnu/store/...-python-protobuf-5.27.3/lib/python3.10/site-packages/google/protobuf/internal'.
+ ;; Expected '/tmp/guix-build-python-protobuf-5.27.3.drv-0/protobuf-5.27.3/google/protobuf/internal'.
+ ;; Is this module globally installed?
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest" )))))))
+ (inputs (list protobuf))
+ (home-page "https://github.com/protocolbuffers/protobuf")
+ (synopsis "Protocol buffers is a data interchange format")
+ (description
+ "Protocol buffers are a language-neutral, platform-neutral extensible
+mechanism for serializing structured data.")
+ (license license:bsd-3)))
+
(define-public python-protobuf
(package
(name "python-protobuf")