aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-05 18:17:12 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-12 08:27:03 -0400
commit3aea350e1644770d31c522f53cce241593174276 (patch)
tree1ff73dc29a8b2d045acfb4384dc126e6e3180803
parent4c229df532b3cd1015cc63aba451920ff740acbb (diff)
downloadguix-3aea350e1644770d31c522f53cce241593174276.tar.gz
guix-3aea350e1644770d31c522f53cce241593174276.zip
gnu: go-1.19: Skip 2 gccgo tests.
* gnu/packages/golang.scm (go-1.19)[arguments]: Add a phase to skip two tests depending on specific versions of gccgo.
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 89f2192274..9c8decda61 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -905,6 +905,17 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(substitute-keyword-arguments (package-arguments go-1.18)
((#:phases phases)
#~(modify-phases #$phases
+ ;; These are recurring test failures, depending on having a new
+ ;; enough version of gccgo. gccgo-12.2 fails with go-1.19.7.
+ ;; https://github.com/golang/go/issues/22224
+ ;; https://github.com/golang/go/issues/25324
+ (add-after 'unpack 'skip-TestGoPathShlibGccgo-tests
+ (lambda _
+ (substitute* "misc/cgo/testshared/shared_test.go"
+ (("TestGoPathShlibGccgo.*" all)
+ (string-append all "\n t.Skip(\"golang.org/issue/22224\")\n"))
+ (("TestTwoGopathShlibsGccgo.*" all)
+ (string-append all "\n t.Skip(\"golang.org/issue/22224\")\n")))))
(replace 'install-doc-files
(lambda _
(for-each (lambda (file)