aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-22 19:10:08 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-26 12:59:35 +0100
commit3a1c3642d4d611c5516a8ba5b6bc7e39bdc1c9ae (patch)
tree43a019c13e38cc1e2821d8b94a58731bd273fca0
parent770ea94c9cde701ae3b45f313799b9d95154c267 (diff)
downloadguix-3a1c3642d4d611c5516a8ba5b6bc7e39bdc1c9ae.tar.gz
guix-3a1c3642d4d611c5516a8ba5b6bc7e39bdc1c9ae.zip
llvm: Add support for the Hurd.
* gnu/packages/llvm.scm (system->llvm-target): Use X86 for i586 (i.e., the Hurd).
-rw-r--r--gnu/packages/llvm.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index ef273e3ef6..e7346ac9ea 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -75,7 +75,8 @@ as \"x86_64-linux\"."
("powerpc" => "PowerPC")
("riscv" => "RISCV")
("x86_64" => "X86")
- ("i686" => "X86"))))
+ ("i686" => "X86")
+ ("i586" => "X86"))))
(define (llvm-download-uri component version)
(if (version>=? version "9.0.1")
im-shepherd-service, gdm-shepherd-service) * gnu/services/base.scm (greetd-shepherd-services): Add PAM requirement. * gnu/system/pam.scm (/etc-entry, extend-configuration, pam-root-service-type, pam-root-service) * gnu/services/authentication.scm (pam-ldap-pam-service) * gnu/services/base.scm (pam-limits-service-type) (greetd-pam-service) * gnu/services/desktop.scm (pam-gnome-keyring) * gnu/services/kerberos.scm (pam-krb5-pam-service) * gnu/services/pam-mount.scm (pam-mount-pam-service): Adapt to use pam-extension. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Josselin Poiret 2023-05-11services: syslog: Do not call 'umask' in PID 1....Fixes a race condition when starting services in parallel with shepherd 0.10.x whereby a service might create files and directories with umask #o137. An example is the bitlbee service with its least-authority wrapper: the wrapper would create a tree with directories set to #o640, thereby making the whole directory tree inaccessible. * gnu/services/base.scm (syslog-shepherd-service): Pass #:file-creation-mask to 'make-forkexec-constructor' instead of calling 'umask' in PID 1. Ludovic Courtès 2023-04-30system: guix: Use config's ACL file location....* gnu/services/base.scm (substitute-key-authorization): Use %acl-file instead of hardcoded "/etc/guix/acl". Signed-off-by: Ludovic Courtès <ludo@gnu.org> Josselin Poiret 2023-04-21services: nscd: Depend on syslogd....This gets rid of nscd debug messages on the console at boot time. * gnu/services/base.scm (nscd-shepherd-service): Add dependency on 'syslogd'. Ludovic Courtès 2023-04-21services: syslog: Log auth.info to /var/log/secure in default configuration....This causes authentication failures such as those generated by SSH brute force attacks to appear in /var/log/secure, which is picked up by tools such as fail2ban. * gnu/services/base.scm (%default-syslog.conf): Add a auth.info selector for the /var/log/secure log. Series-to: 62802@debbugs.gnu.org Maxim Cournoyer 2023-04-21services/syslog: Strip leading white space indent in syslog.conf....This is a cosmetic change. * gnu/services/base.scm (%default-syslog.conf): Add a comment referencing the documentation. Strip the extraneous leading trailing white space indent. Maxim Cournoyer 2023-04-21services: syslog: Add a reload action....* gnu/services/base.scm (syslog-service-type) [actions]: Add a reload action. * doc/guix.texi (Base Services): Document it. Maxim Cournoyer 2023-04-21services: syslog: Move configuration to /etc/syslog.conf....Having the configuration live at a static location makes it possible to hot-reload it. * gnu/services/base.scm (syslog.conf): New variable. (syslog-etc, syslog-shepherd-service): New procedures. (syslog-service-type): Rewrite using the above new variable and procedures, extending etc-service-type with its configuration file. Maxim Cournoyer 2023-04-17services: agetty: 'term-console' succeeds by default....Previously, on a typical setup without "console=ttyS0" or similar in 'kernel-arguments', the 'term-console' Shepherd service would always be marked as failing to start. This is undesirable because it raises a false alarm: the service is expected to do nothing in this case. This patch instead marks it as succeeding and logs a message explaining it's doing nothing. * gnu/services/base.scm (agetty-shepherd-service): In 'start' method, succeed when TTY is #f and print a message. Ludovic Courtès 2023-04-07services: guix-publish: Remove 'compression-level' field....* gnu/services/base.scm (<guix-publish-configuration>)[compression-level]: Remove field. (guix-publish-configuration-compression-level): Remove procedure. (default-compression): Remove compression-level helper code. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Bruno Victal 2023-04-07services: base: Remove 'console-font-service' procedure....* gnu/services/base.scm (console-font-service): Remove procedure. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Bruno Victal 2023-04-07services: base: Remove 'console-keymap-service-type' variable....* gnu/services/base.scm (console-keymap-service-type): Remove variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Bruno Victal 2023-03-30services: pam-limits-service-type: Deprecate file-like object support in favo......* doc/guix.texi (Base Services): Document it. * gnu/local.mk: Register test. * gnu/services/base.scm (pam-limits-service-type): Accept both lists and file-like objects. Deprecate file-like object support. * gnu/tests/pam.scm: New file. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Bruno Victal 2023-03-30services: base: Deprecate 'pam-limits-service' procedure....* doc/guix.texi (Base Services): Replace pam-limits-service with pam-limits-service-type. * gnu/packages/benchmark.scm (python-locust)[description]: Update index anchor to manual. * gnu/services/base.scm (pam-limits-service-type): Set default value. (pam-limits-service): Deprecate procedure. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Bruno Victal 2023-03-27services: syslog: Add 'configuration' action....* gnu/services/base.scm (syslog-service-type): Add 'actions' field. Ludovic Courtès