aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-04 11:48:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-04 12:00:13 +0200
commit2e77bbed719cfaa43d704e555a9007c5c4d52d2f (patch)
treedea69ec07db9865f29e70c492a3f6d20087bc454
parentd4b5e4bb7377a31196b392c93b0072aed9cc969a (diff)
downloadguix-2e77bbed719cfaa43d704e555a9007c5c4d52d2f.tar.gz
guix-2e77bbed719cfaa43d704e555a9007c5c4d52d2f.zip
gnu: ruby@2.3: Update to 2.3.8.
* gnu/packages/ruby.scm (ruby@2.3): Update to 2.3.8.
-rw-r--r--gnu/packages/ruby.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7e8c8be290..bdcc3214e6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;;
@@ -110,7 +110,7 @@ a focus on simplicity and productivity.")
(define-public ruby-2.3
(package
(inherit ruby)
- (version "2.3.7")
+ (version "2.3.8")
(source
(origin
(method url-fetch)
@@ -119,7 +119,7 @@ a focus on simplicity and productivity.")
"/ruby-" version ".tar.xz"))
(sha256
(base32
- "1nwfaifq5624p1ml56qq5dy5w38z37x22r0qgrbgbzrzklmqy7y6"))
+ "1zhxbjff08pvbnxvn58krns6q0p6g4977q6ykfn823gxhifn63wi"))
(modules '((guix build utils)))
(snippet `(begin
;; Remove bundled libffi
le (gnu services networking) #:use-module (guix gexp) #:use-module (guix store) #:use-module (guix monads) #:export (%test-tailon)) (define %tailon-os ;; Operating system under test. (simple-operating-system (dhcp-client-service) (service tailon-service-type (tailon-configuration (config-file (tailon-configuration-file (bind "0.0.0.0:8080"))))))) (define* (run-tailon-test #:optional (http-port 8081)) "Run tests in %TAILON-OS, which has tailon running and listening on HTTP-PORT." (define os (marionette-operating-system %tailon-os #:imported-modules '((gnu services herd) (guix combinators)))) (define vm (virtual-machine (operating-system os) (port-forwardings `((,http-port . 8080))))) (define test (with-imported-modules '((gnu build marionette)) #~(begin (use-modules (srfi srfi-11) (srfi srfi-64) (ice-9 match) (gnu build marionette) (web uri) (web client) (web response)) (define marionette ;; Forward the guest's HTTP-PORT, where tailon is listening, to ;; port 8080 in the host. (make-marionette (list #$vm))) (mkdir #$output) (chdir #$output) (test-begin "tailon") (test-eq "service running" 'running! (marionette-eval '(begin (use-modules (gnu services herd)) (start-service 'tailon) 'running!) marionette)) (define* (retry-on-error f #:key times delay) (let loop ((attempt 1)) (match (catch #t (lambda () (cons #t (f))) (lambda args (cons #f args))) ((#t . return-value) return-value) ((#f . error-args) (if (>= attempt times) error-args (begin (sleep delay) (loop (+ 1 attempt)))))))) (test-equal "http-get" 200 (retry-on-error (lambda () (let-values (((response text) (http-get #$(format #f "http://localhost:~A/" http-port) #:decode-body? #t))) (response-code response))) #:times 10 #:delay 5)) (test-end) (exit (= (test-runner-fail-count (test-runner-current)) 0))))) (gexp->derivation "tailon-test" test)) (define %test-tailon (system-test (name "tailon") (description "Connect to a running Tailon server.") (value (run-tailon-test))))