aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2025-02-23 10:23:49 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2025-02-23 10:55:33 +0100
commit2ae74fb0b718e51814e454113de9474a49a3eadc (patch)
tree8d89032dcf1e03a3dcaad8bce92cb3e6a7980678
parent9756699849b381a60f8336077af5494ac59ca27d (diff)
downloadguix-2ae74fb0b718e51814e454113de9474a49a3eadc.tar.gz
guix-2ae74fb0b718e51814e454113de9474a49a3eadc.zip
gnu: Add lc0.
* gnu/packages/lc0.scm: New file. * gnu/packages/local.mk: Register file. Change-Id: Ib3a8719c4e4da69e2ad5e9d5dd14307197973c7f Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/lc0.scm72
2 files changed, 73 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 73116fdc1b..257b66d1c2 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -424,6 +424,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/kerberos.scm \
%D%/packages/kodi.scm \
%D%/packages/language.scm \
+ %D%/packages/lc0.scm \
%D%/packages/lean.scm \
%D%/packages/lego.scm \
%D%/packages/less.scm \
diff --git a/gnu/packages/lc0.scm b/gnu/packages/lc0.scm
new file mode 100644
index 0000000000..c7dad28ecd
--- /dev/null
+++ b/gnu/packages/lc0.scm
@@ -0,0 +1,72 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages lc0)
+ #:use-module (guix build-system meson)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages c)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages machine-learning)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python))
+
+(define-public lc0
+ (package
+ (name "lc0")
+ (version "0.30.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LeelaChessZero/lc0")
+ (commit (string-append "v" version))
+ ;; Only a few source files are in one Git submodules
+ ;; (rather than there being bundled projects). These
+ ;; files are in a different repository just because they
+ ;; are used across multiple repositories of the Leela
+ ;; Chess Zero project.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m7k8m8iz4pxv3h9g2j1dkgryi4k9c1bcg3fx5j7ii4ysif63kj3"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "-Ddnnl=true"
+ (string-append "-Ddnnl_dir="
+ #$(this-package-input "oneapi-dnnl")))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "XDG_DATA_DIRS")
+ (files '("share")))))
+ (inputs (list eigen oneapi-dnnl zlib))
+ (native-inputs (list googletest ispc pkg-config python))
+ (synopsis "Chess engine based on neural networks")
+ (description
+ "Leela Chess Zero is a UCI-compliant chess engine designed to play chess
+using neural networks. This package does not provide a neural network, which
+is necessary to use Leela Chess Zero and should be installed separately.")
+ (home-page "https://lczero.org")
+ (license license:gpl3+)))