aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-16 17:43:45 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:15 +0200
commit29d5767343565b557d796107fa699affca107bda (patch)
tree22c37569c6cc6c9974927416dd1c735cc7581501
parent4ed3e4671508277b8a04941b163acf3141801af6 (diff)
downloadguix-29d5767343565b557d796107fa699affca107bda.tar.gz
guix-29d5767343565b557d796107fa699affca107bda.zip
gnu: git-minimal: Avoid depending on (guix search-paths).
This is a follow up commit to 48e528a26f, following discussions in <https://issues.guix.gnu.org/65924#96>. * gnu/packages/version-control.scm (git-minimal) [arguments] <imported-modules>: Remove. <modules>: Remove (guix search-paths); add (ice-9 format). <phases>: Rewrite PATH-variable-definition in the patch-commands phase to avoid the use of (guix search-paths). Suggested-by: Ludovic Courtès <ludo@gnu.org> Change-Id: I01a3c4be780f11434200c6f47739dc52a75ea51a
-rw-r--r--gnu/packages/version-control.scm24
1 files changed, 7 insertions, 17 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index ff985de1ce..6098c119fa 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -89,7 +89,6 @@
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (guix build-system trivial)
- #:use-module (guix modules)
#:use-module (gnu packages apr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages documentation)
@@ -259,14 +258,11 @@ Python 3.3 and later, rather than on Python 2.")
(build-system gnu-build-system)
(arguments
(list
- #:imported-modules `(,@%gnu-build-system-modules
- ,@(source-module-closure '((guix search-paths))))
- #:modules `((ice-9 match)
- (ice-9 textual-ports)
- (srfi srfi-1)
+ #:modules `((srfi srfi-1)
(srfi srfi-26)
+ (ice-9 format)
+ (ice-9 textual-ports)
((guix build gnu-build-system) #:prefix gnu:)
- (guix search-paths)
,@%gnu-build-system-modules)
;; Make sure the full bash does not end up in the final closure.
#:disallowed-references (list bash perl)
@@ -342,16 +338,10 @@ Python 3.3 and later, rather than on Python 2.")
(display content port)))))
(define PATH-variable-definition
- (let ((value
- (match (evaluate-search-paths
- (list $PATH)
- (list #$(this-package-input "coreutils-minimal")
- #$(this-package-input "sed")))
- (((spec . value))
- value))))
- (string-append
- (search-path-definition $PATH value
- #:kind 'prefix) "\n\n")))
+ (format #f "PATH=~{~a~^:~}${PATH:+:}$PATH~%~%"
+ (map (compose dirname (cut search-input-file inputs <>))
+ '("bin/basename"
+ "bin/sed"))))
;; Ensure that coreutils (for basename) and sed are on PATH
;; for any script that sources the 'git-sh-setup.sh' file.