aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-08-20 16:20:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-08-20 16:41:39 +0200
commit29a33257081bf4f5231bd4b945a66304b6eb7a9c (patch)
tree03d74ba604cd55e134507aa98b05a1e74de7ab09
parent3fa1b0821366113cf077385f0180e6071bff4308 (diff)
downloadguix-29a33257081bf4f5231bd4b945a66304b6eb7a9c.tar.gz
guix-29a33257081bf4f5231bd4b945a66304b6eb7a9c.zip
gnu: bundler: Update to 1.15.4.
* gnu/packages/ruby.scm (bundler): Update to 1.15.4.
-rw-r--r--gnu/packages/ruby.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 25b2dd33f7..243ff9e5db 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -464,13 +464,13 @@ expectations and mocks frameworks.")
(define-public bundler
(package
(name "bundler")
- (version "1.15.3")
+ (version "1.15.4")
(source (origin
(method url-fetch)
(uri (rubygems-uri "bundler" version))
(sha256
(base32
- "125amldnpzzrfw76mmr7mlx002k1k6xdyrqf5bdnzl5hajvn0s5f"))))
+ "0wl4r7wbwdq68xidfv4hhzfb1spb6lmhbspwlzrg4pf1l6ipxlgs"))))
(build-system ruby-build-system)
(arguments
'(#:tests? #f)) ; avoid dependency cycles
))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list tree-sitter-javascript
+ tree-sitter-python
+ tree-sitter-typescript))
+ (native-inputs
+ (list python-minimal))
+ (home-page "https://www.masteringemacs.org/article/combobulate-structured-movement-editing-treesitter")
+ (synopsis "Structured editing and navigation in Emacs with tree-sitter")
+ (description
+ "Combobulate is a package that adds structured editing and movement to
+a wide range of programming languages. Unlike most programming major modes
+that use error-prone imperative code and regular expressions to determine
+what's what in your code, Combobulate uses Emacs 29's tree-sitter library.
+Tree-sitter maintains a concrete syntax tree of your code; it gives
+Combobulate absolute clarity of all aspects of your code, enabling more
+correct movement and editing than you would otherwise have.")
+ (license license:gpl3+))))
+
(define-public emacs-compat
(package
(name "emacs-compat")